Raspberry Pi 3b+ suddeny not booting

Hi Guys I’m pretty conffused and hope you can help me…

I’ve been through the proces multiple times now. I install OSMC on an SDCard, put into the Pi and boot it. I get some Addons (MagicDragon, Netflix, etc.) and everything works fine. Then I shut it down, don’t use it for a while and when I want to boot it again: NOTHING. Nothing on the screen, can’t reach it via SSH, Nothing. I don’t have any idea why this is. Please help me.

What are the LED’s saying?
Is your power supply up to the job?
Have you tested your SD Card with H2Testw?
Does it happen if you don’t install the banned addons/builds?

The LED’s are working normal, The power supply is also up to the job. Just did H2testw… no problem.
What do you mean wirth banned?


Thank you, I’ll try it without magicdragon

I tried it once again. The only thing I did was installing the Netfllix Addon, which isn’t banned as far as I know… SAME RESULT

Well than must be Hardware (Pi itself), SD Card or Power Supply/Cable.

Well, had no problem since changing to libreelec…

If LibreELEC works for you, then use that.