Raspberry Pi Display not turning off on shutdown


#1

Hello!
I have a problem with OSMC on a Raspberry Pi 3 in combination with the official 7" touchscreen. Everything is connected as it should be and the display works fine while in use, but it does not turn off, when I shutdown OSMC and the Pi. It starts showing white and black lines that fade into grey, but still stay there and also the backlight stays on. This only happens with OSMC, not with raspbian or other systems I tried. I also tried multiple versions of OSMC, including the latest one from March, without any success.
i would be glad if anyone could help me with my problem!
If you need further details, please let me know!

zurafta


#2

I have the same problem.
I think this is a real big problem for using OSMC as media player with touchscreen.

My system:
Raspberry PI 3 model B, Official 7" touchscreen
OSMC 2018.10-1


#3

What version of OSMC are you using?

Sam


#5

I installed the latest version 2018.10-1 and then upgrade it.

I checked two screen power schemes:

  1. Get power from RPI GPIO to pins on touchscreen (only two wires 5V, GND)
  2. Only two micro-USB separately for each (without connecting any GPIO)

The result is the same: when I turn off the OSMC, the RPI turns off and the touchscreen flashes (as described @zurafta) until I turn off the power of the touchscreen.


#6

Update:

I checked the following commands over ssh. They work.

Turn on backlight:

echo 0 > /sys/class/backlight/rpi_backlight/bl_power

Turn off backlight:

echo 1 > /sys/class/backlight/rpi_backlight/bl_power

Of course I can write a script with turn off command and put it to /lib/systemd/system-shutdown (it work, I checked). But in my opinion, this is the wrong decision.

Video with issue:


#7

I wonder if Raspbian does something in user-space to handle this. We are up to date with Device Tree and kernel; so I don’t think it’s firmware related.


#8

Thank you, Sam

It turned out that they do the same thing.
I found systemd service file in

/lib/systemd/system/rpi-display-backlight.service

[Unit]
Description=Turns off Raspberry Pi display backlight on shutdown/reboot
ConditionPathIsDirectory=/proc/device-tree/rpi_backlight
DefaultDependencies=no
Before=umount.target

[Service]
Type=oneshot
ExecStart=/bin/sh -c ‘/bin/echo 1 > /sys/class/backlight/rpi_backlight/bl_power’

[Install]
WantedBy=reboot.target halt.target poweroff.target

I hope in the next update there will be a solution that does not require users to do anything.

Andrew


#9

Hold Your Head Up

I’m sure we can get something included shortly.


#10

I heard that donations to OSMC may help for hopes to become reallity :wink:


#11

I heard (with my ears) that the Argent version is better.


#12

@zurafta has long been absent. Who can mark this topic as solved please.


#13

Done (which means we trust @sam_nazarko fixes it in next release.


#14

I am not gone actually, but after nobody could help my here back then I could not just wait for over a year so someone would dig out my old post to get help on this topic too, so I simply could not use OSMC for my project back then. I am glad you got it fixed and I would really hope it would finally get fixed officialy for everyone as I really like OSMC and appreciate the work you put into it! :slight_smile:


#15

I think the solution to this problem is currently here.
Sorry for my humble ))


#16

This is now included and will be in the next update

Sam