Raspberry Pi PoE Hat Fan Control


the Raspberry Pi PoE Hat Fan Control has changed after the last update. Before the update the fans were silent and after the update, they are sporadically very loud. Is something changed to the fan control with the update? IS there anything I can do?

I’m using one RPi in my bedroom and now it is not usable anymore.

I’m using the atest OSMC stable release and RPi 3+ and 4.

Fan support wasn’t implemented properly in previous versions.
The support is now implemented properly in the August update

You can change the temperatures when it comes on to make it less aggressive. You can use the following as a reference but note that you would be putting these settings in config-user.txt with the current builds of OSMC.


Thank you. I will try the fan config.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Hi Sam,

I have updated OSMC on two RPs(3 and 4) and removed the dtparam=poe_fan_temp setting from the config-user.txt

I will test it.

1 Like

Thanks, keep me posted.

HI @sam_nazarko

i had to reactivate the dtparam in the user config. The fan randomly turn on with full speed, even while beeing idle.
If I can help further, please let me know.

Please post logs so I can see if you updated. I cannot reproduce this.

Hi @sam_nazarko

I have uploaded the logs. If you need other logs, please let me know.


But I can live with the dtparam=poe_fan_temp in the config file.