Raspberry WiFi doesn't work properly

Hi all,
I have a Raspberry Pi 3 + Allo Boss Dac with the latest OSMC release, unfortunately I have some problems with the WiFi, it can’t connect to my wifi network because the Rasp doesn’t see the network, sometimes the network is visible and the most of time no. The router is near the Raspberry.
I haven’t this problem if I use the hotspot of my iphone, or if I mount the SD with Raspbian.

I had this problem also with the previous OSMC releases.

How can I fix the problem?


We would need to see some logs when the WiFi disconnects.
You could attach an Ethernet cable temporarily to upload these logs.


No logs available, because the issue is that the Raspberry doesn’t see the network.


Are you using the in builtin wifi or an external adaptor?

Is the the wifi network 2.4ghz or 5ghz or both?

If its both do you a have a separate SSIDs for 2.4 & 5 ghz networks?

What’s the make of the router?

How close? Maybe easier just to connect with a network cable.

Thanks Tom.

I am using builtin wifi.

My router is Zixel Multy Pro AC2400 VDSL2 (firmware, 2.4ghz and 5ghz, I use both.

I tried to turn off the 5ghz, but the issue remains the same.

I can’t use a cable connection.



Sounds like the pi could have a hardware fault, couple of options to help diagnose:

  1. Temporarily run network cable and upload logs, as Sam suggested.

  2. Install raspbian on a spare sd card and see if wifi is working there.

Thanks Tom.


  1. I will try it.
  2. It works, as I wrote in my first post, if I insert a SD with Raspbian the wifi works properly.

I think it’s a software bug.

We need to see some logs

Bugs are not defined by feelings. Only logs can define a bug.


Please, how can I activate the logs? At the moment, there aren’t logs.

Have you connected the Pi by cable? If so, you can send logs from My OSMC > Log Uploader. Select all options.



Is there anybody out there? :grinning:

The hardware is faulty.

I don’t think so, because it works fine with an another OS (Raspbian)

The log doesn’t seem to show that the WiFi is faulty – but it doesn;t show much at all, since the Pi was connected by cable.

You’ll need to try a few things from the command line, with the cable attached.

enable wifi
scan wifi
agent on

If you see your router’s SSID, try to connect:

connect wifi_xxxxx_yyyyy_managed_psk

It should prompt you for a password. If it looks ok, run ifconfig.

Please copy/paste all the output here, so we can see what’s happening

It looks like it cannot complete scans.
Either it’s defective or not getting enough power.