Raspberry with OSMC does not boot any more

Hi All,

My Raspberry Pi 2 Model B with OSMC does not boot anymore. Last time I used it I watched a movie and did the upgrade. Everything seemed ok.

Now I am able to see files on my SD on MAC and with my surprise, I do not see the home folder and stuff like that (the one I see when I access to my Raspberry in ssh). I see dtb files, start_x.elf and so on.

When my Raspberry starts I see the green led blink 4 times. Reading some forum I find out it is something wrong with start_x.elf. No signal and no output on TV.

Now my question is: how I can recover the situation?

I would like to backup my /home/osmc/.kodi folder but I do not know where is it on the SD.

Can anyone help me to figure out how to solve this issue?
Thanks in advance for help.

PS
I have official power supply 2A

The SD Card has too partitions

  1. The boot partition which is the one you see
  2. The Root/Home partition which you don’t see because AFAIK MAC OS natively can not read EXT4.

So if you really can not get it boot in the Pi your only option is to find a way to ready EXT4 (e.g. running a Linux Live CDROM in a virtual Machine)

No chance to recover my image? Looking on the web I found that 4 flash means start_x.elf corrupted. I could take it from here

but not sure if the latest firmware is the one I have installed on my machine.

Any other idea?

In case I cannot restore the SD image and I am able to access to home partition, which file should I backup? Is /home/osmc/.kodi sufficient?

that will give you a backup of all Kodi(Mediacenter) personal settings so normally good enough.

It might be worth checking the md5sum of /boot/start_x.elf. I’m seeing a value of 613aa2a56969328b3534e558bd15db14 on the latest build.

Perhaps @fzinken can confirm that this value is correct. I don’t have remote access right now.

Yes, that value is correct

new start_x.elf does not solve issue.

However, suppose I backup my /home/osmc/.kodi, in order to have everything up and running, should I install OSMC from scratch and then copy back the content?

Yes

Ok, thank you, everyone, for the reply.
The last question, in your opinion, if the problem is the boot partition, can I download and copy the master branch of this GitHub - raspberrypi/firmware: This repository contains pre-compiled binaries of the current Raspberry Pi kernel and modules, userspace libraries, and bootloader/GPU firmware. and copy it on my boot partition. Are you aware of any particular hidden files?

Why do you insist on attempting to use a FW other than OSMC provided? You know OSMC has a github where you can find these files?

Sorry, I didn’t know OSMC had is own firmware. Where I can download it?

Hi again, I wasn’t able to see my EXT4 partition on Mac via Virtual box but I did it with osxfuse/ext4fuse. I did a backup of /home/osmc with the command:
rsync -arv /Volumes/rpi/home/osmc

Now I have two possibilities:

  1. reinstall OSMC on my SD card and copy back my backup on it. I know how to do that.
  2. Download OSMC raspberry firmware and copy it in boot and check if it works.

I would prefer option 2 but I do not know where to download it. Is there any github repo for it? I tried to search it with no success.

You’ve already made the backup. You could already have made a fresh install and been restoring that backup in the time between your last post and this one.

Yes, I know. But when I do things like that I have always fear that something goes wrong during restore. In this situation I do not have recovery any more.

Irrational fear now after you have taken a backup? You weren’t very concerned about a backup solution last time it all worked? I’m not sure what you think will go wrong during a restore…

After 30 years working with computers fear is never irrational :slight_smile:
A restore like this has always surprises.
In fact, I have issues.

I installed OSMC and it worked.
Then connected via SSH and done the following:

  1. mv .kodi .kodi.backup
  2. copied the original .kodi + some other files in my home.

I got a sad emoticon that appears repeatedly on TV. in kodi.log I have the following error lines:

02:34:03.383 T:1926396416 ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
02:34:03.748 T:1926396416 ERROR: CSettings: unable to load settings from special://masterprofile/guisettings.xml, creating new default settings
02:34:20.399 T:1906307840 ERROR: DoWork - Direct texture file loading failed for resource://resource.images.weathericons.default/.png
17:14:46.188 T:1926396416 ERROR: Control 20010 in window 13001 has been asked to focus, but it can’t

I have the impression that is something related to skin settings that cannot be uploaded. I had estuary skin in my old installation.

Hi again,

I wrote my message too early, sorry for this.

I fixed the issue. I switched back to default .kodi. Configured Settings and switched to Estuary skins and then a went back to my original .kodi of previous installation. It worked.

Tomorrow, I’ll test everything (addons, TV, Music, Movie, etc.) and I’ll let you know.

Thanks in advance for your help.

I had several times the same issue after a power-fail.
Edit the config.txt file and insert a line with the text: start_x=1 in it.
You need another computer to do this.

To @ooZee about his comment below here. Be careful being arrogant mister. In the discussion they let someone reinstall OSMC unnecessarily. Let me tell you that there is a problem with OSMC that under certain circumstances the config.txt file will be emptied. Second, old threads are useful for other people looking for answers so what is wrong about my comment?

4 Likes

That line should already be included. And this is a two-years-old post.

1 Like