Raspmc Settings Addon - Network Settings

HI,
We had storm over weekend and I shut down all devices. When I started up on Sunday night, my Pi could no longer access the network. Every other device could. I Swapped Ethernet cables as well. Still no good.

I have a feeling network settings may have changed when everything came back. I tried to play around and managed to get an IP address on the XBMC System Info screen (i’m running 13.2) but it wont appear on network or connect to internet.

Can someone tell me what I need to be looking for in my router settings to put into the Raspmc Settings Addon? I use this as I have never SSH in. I’m sure this is what is wrong as i was making small progress, just not sure exactly what to put in. DCHP, servers ect…i’m not sure.

Any help would be appreciated.

Thanks,
Mark.

Unless you have specifically set static IP’s for your device (and I would think you would remember doing that if that was the case) then you want DHCP.

1 Like

You may want to consider upgrading to OSMC as well as Raspbmc is EOL.

1 Like

Thanks. I haven’t set static IPs. Im sure it was DCHP before as well. However now when it is set on the System Info of Network. It says LINK:NOT CONNECTED with no MAC address no IP address no subnet mask no gateway and INTERNET: NOT CONNECTED CHECK NETWORK SETTINGS

And Sam, i plan to upgrade as soon as i can get an SD card reader that works!

Not sure if these help. The 3rd shot is from my router… Strangely i rebooted it and it appeared in the trusted MAC list but in XBMC that MAC number is not listed…

Im sorry about the dodgyness of the photos. The Pi is in the living room and this Vodafone tablet takes horrible photos.

Any idea guys? Should there be something in my router i need to look at? I can restore to original XBMC version… To extreme?

The IP addresses shown in your Raspbmc screenshot are clearly wrong - they’re not in the same subnet as the router, however the blank mac address is worrying too. It’s so long since I’ve used Raspbmc that I can’t even remember how the networking GUI works - maybe these IP addresses are “default” addresses that the GUI shows until DHCP has allocated an address.

You quite likely need to reinstall, however Raspbmc has been unsupported for over 6 months now so it’s probably time to bite the bullet and install OSMC. At least with OSMC you will be current and running a system that is actively supported and updated.

The only thing to keep in mind is that you would be jumping from the Gotham 13.2 version of Kodi to Isengard 15.2.

Yes they are the default settings. I resorted to them when nothing else worked.

I will bite the bullet and reinstall using Isenguard. Is there any chance i could be presented with the same scenario when i get it running?

Since we don’t know what the cause of the problem is, that’s a difficult question to answer…

It doesn’t seem very likely though.

1 Like

Install of OSMC went well. Was so pumped. Fired it up and no joy :frowning:

Still no Mac Address. Internet not connected. When OSMC boots and it does the HTTP request for the time, it times out. In the OSMC settings I try and “Configure Network Using DHCP” but it just comes back to the manual entry options. I’m wondering if my Ethernet port is somehow stuffed?

I’ve tried different ethernet cables which work in other devices, i’ve even bypassed the switch and plugged straight into the router. The port light is orange (others blue) but I believe that is just related to speed? I also tried a wall charger instead of the usb cable I had been using but still no MAC address.

It sounds like it is hardware related, but would it have made a difference if I didnt wipe the memory card before installing? I just assumed the new image would overwrite whatever is on there…

Hmmmm this appeared in my trusted devices list in my router settings:

Is there someway to “remind” the Pi of this MAC address?

EDIT - i just went to log into my NAS and realized that the IP address I had book marked in web browser has changed…if my router changed the IP address of the Pi, would that have caused my issues?

Amongst other signs, the MAC showing as all zeroes in the OSMC info settingssuggests that the port is ‘blown’.
If this is so, then the only way round that occurs to me is to get a usb-to-ethernet converter to plug into the usb port on the Pi.
Caveat: I’ve bought and tried a couple of these, but only one works with the Pi ‘out of the box’.
Derek

Hi Derek,

Can I ask which one worked for you? Some of the branded ones cost almost as much as a new Pi 2!

I’m hoping a $2 ebay job would work?

Or should I be looking at wireless?

Mark.

Not sure if this is relevant to my issue, but I tried to connect the tablet to the NAS to check wifi transmition speeds in the lounge room and the NAS IP address had changed from what was in ES Explorer on the android tablet before the storm.

Changing the IP address found the NAS, but I couldnt log in…Could there be some sort of network permissions in the router that would not allow the Pi and my Tablet to connect to devices? The tablet can still access the wifi internet though. And my Blu Ray player can access the NAS…

I vaguley remember some sort of permission in Windows Homegroup or somewhere when I first set up but now cant find.

The one I used which works is Edimax EU-4208 USB 2.0 to 10/100Mbps Ethernet Adapter
£11.99 from amazon in august 2014.
There are plenty of Wifi adapters which work well, but for some the drivers have been known to require special attention.
Derek

Thanks Derek. I found that one locally for a good price: http://www.msy.com.au/peripherals/15841--edimax-eu-4208-usb20-10-100-ethernet-adapter.html

But according to this list http://elinux.org/RPi_USB_Ethernet_adapters it needs its own power source which is another $25+ to the price…

Do you use a powered hub with yours?

I went through that whole list snd couldn’t find anything that was cheaper than a new Pi :frowning:

Personally I would not be wasting money on a $25 USB Ethernet controller for a Pi 1 with a faulty Ethernet port - put the money towards a Pi 2, you won’t be disappointed…

I have one Pi 2 and two Pi 1’s (a B and a B+) and the Pi 1’s don’t even get plugged in anymore…

Klattsy: I think I used a powered hub, as it was for a RPi1A (which has only 1 usb socket).
I’d agree with DBM’s view, when faced with the additional expenditure.
Derek

Ok. Thanks guys.