RC3 update stuck at 100%


just tried to update to RC3 (from RC2). Went to Update and after downloading some files and again update and downloading files it asked me to restart. so i said yes.
Went away for about half an hour and when i came back it shows screen: Installing packages -> Running dpkg -> 100%

I guess it is stuck there. Tried to connect via SSH but connection refused.

Can i just cut the power to the Raspberry (which i will have to anyway)? Will it be broken?


1 Like

Press ctrl-alt-delete on a USB keyboard if you can, that will at least do a controlled shut down that won’t cause file system corruption.

If it doesn’t respond to ctrl-alt-delete it may just be that the system has hung. (Probably too much overclock or inadequate power) Please upload full debug logs after rebooting so we can see what went wrong.


Just put out and in power and it works now. I did not overclock it and power I do not know (had it from the beginning like this). If it is on my side it would be nice if you could tell me so i can fix it :smile:

I was just about to post a similar thread. Did you also do a manual update?

Mine also hung after the restart. Did a fresh install of RC3 and it worked perfectly so I just assumed it was the manual update that was causing a problem.

Yes, manual.

Doesn’t matter whether you initiate updates manually or via a schedule - the exact same update process occurs.

If you get any error messages or freezes during updates please post a full debug log so we can try to identify the cause.