RC6 Remote showing slight change in Behaviour - MCE Button

Well first and foremost I am going to apologise for going off topic right at the start of this post!

I am not surprised as such but slightly in awe of how amazing Sam and your team are. Just moved first pi running RaspBMC Kodi to 14.1 to OSMC Kodi 14.2. Why am I in awe? Because in this day and age we all expect something for nothing, like to gripe about it, and often there are trivial gripes to be picked up on.

NO, no ,no :smile:

Fantastic service, as usual, I can’t think of a gripe, even if I imagine myself in a very dark mood after a bad day! LOVE the new installer, LOVE the new Forum. There has been a load of work obviously here and I want to congratulate you Sam and all of your team. TOP work.

My issue? Different behaviour with my MCE Remote with what I would call the Green Main Centre Button that would always bring me back with RaspBMC to either the home screen or more importantly the Kodi video/audio options when watching a playback.

I had a look to see if I could edit these myself but couldn’t even find the right Lirc file when ftp’ing in?

Probably not enough info and really appreciate any info back as to what to do.
Thank you all, amazing

This is probably editable in /usr/share/kodi/system/keymap/remote.xml. I doubt your issue lies in LIRC.xml, because we haven’t really changed button mappings there, and it’d be more likely to be your issue if the remote did not work at all.

Thanks for the kind words.


Hi Sam et al, I thought it was probably something as simple as this. However if I ftp in with WinSCP the system folder on both my Pi running RaspBMC and a pi running OSMC appear as empty folders in the window view. How do I get to see the contents of these folders? Do I have to log in as root or something? Or should I be accessing this folder another way?

Kind words cost nothing and I am so impressed!

Is there some reason you’re not using SSH? If you’re using Windows, get Putty.

I couldn’t imagine configuring a Pi via FTP. Plus, could cause a lot of problems if you use windows programs to edit linux config files/scripts.

Yes indeed kind Sir/Madam, because for some of us using SSH combined with Linux commands is like Atlanteans talking Afrikaans?! I can SSH in but after that I am a Windows boy! Linux talk means nothing to me!

I should add that I have Putty, had it for ages since ago. Can do some basic stuff with it, mainly under instruction after that who knows/I can probably do as much damage with Putty and SSH as I can by doing anything else :wink:

You would probably edit the file with sudo nano command.

Don’t use FTP in WinSCP, use SCP and you can browse the system like it’s a local folder. If you edit the connection in advanced and change the shell to “sudo -s” then you will have full control of everything. Change the default text editor in WinSCP to Notepad++ and you’re all set

You could do all that.

Then again, you could learn a few basic linux commands and be well on your way to having a much easier time of using your Pi.

Here’s a few to get you started:
ls - lists a directory’s contents
ls -al lists a directory’s contents including hidden files
vi, vim, nano - basic text editors you can choose from
cd - change directory
find - lists files
grep - filters results to show you only what you need from any given output
~ - represents your home directory
/ - represents your root directory


osmc@osmc:~$ ls -al | grep kodi
drwxr-xr-x 8 osmc osmc    4096 May  1 00:27 .kodi
osmc@osmc:~$ cd .kodi
osmc@osmc:~/.kodi$ cd userdata/
osmc@osmc:~/.kodi/userdata$ cd ~
osmc@osmc:~$ find | grep Lircmap.xml
osmc@osmc:~$ cd .kodi/userdata/
osmc@osmc:~/.kodi/userdata$ vi Lircmap.xml 

I switched directories a couple times to show you how. Then I did a search for Lircmap.xml then opened it in vi to edit it. Don’t be intimidated, you don’t know enough to be dangerous - yet.

Thank you all so far. This has been a very good and productive post with not to be surprised by very helpful comments.

For some reason I am still not able to see the directory contents using Dilligaf’s method.

And thanks leetwanker I think I will have to give that a go next. The only reason I am scared is not wanting to ‘destroy’ what I have working already :wink:

I’ll keep this thread alive until I can sort this issue. In the meantime I have found something even more important to me than a missing home key using a remote. That is to do with video output. Will post that on new discourse.

Once again very much appreciated and great community.

Hi there

I am having the same problem. Since switching to OSMC, the Green button doesn’t work on the mce remote. I checked the remote configuration in osmc settings and switched over to the mce remote option.

At that point, the Green button takes me to the home screen as expected, however the left and right now move twice each press, not once.

I thought if I went back to osmc-remote-lircd, I could just add the KEY_GREEN statement from the rc6 conf, but that didn’t work unfortunately.

Would anyone know how to either add the KEY_GREEN statement to the osmc-remote-lircd or fix the double press issue with rc6-mce-lircd?

Many thanks in advance

Hi Dave,

A bit more information is required here, including log files. Can you turn on debugging in Kodi, reproduce the double press issue then use the Log uploader to upload your logs ?

I’m not sure why you think using osmc-remote-lircd will work for you - the OSMC remote (the one bundled with the vero and possibly sold separately soon) is an RC5 protocol remote not RC6, so it won’t work for you.

The best way to debug these kind of key mapping problems is to turn on debugging mode in Kodi (as above) and tail the kodi log file over an ssh connection, that way when you press a button you can see immediately what key codes are being sent. To tail the log file:

tail -f /home/osmc/.kodi/temp/kodi.log

What type of receiver are you using for your remote ?

A double button response may be due to both lircd and the kernel recognising your remote - this won’t happen with a GPIO receiver but might happen with a USB receiver, as some USB remote receivers will be recognised as a keyboard device and thus will send some buttons such as direction keys even without the assistance of lircd.

Hi, thanks for the response.

Excerpt from the log on pastebin, I think you are right that it is using keypress as well as the remote. As you can see individual key information and then, when I changed to the RC6 module, everything is listed twice.


When I was on Raspbmc, there was an option to choose to use keypresses, I can’t find that now.

I am using an MCE RC6 remote with the original USB receiver. As for the osmc-remote-lircd working. This was the default option when I installed OSMC and my MCE remote worked immediately. I only noticed that an RC6 option existed when I was looking to find out why the green button had stopped working. When I leave it on osmc-remote-lircd, it works perfectly except for that button.

Incidentally, the code for the Green button in the rc6 conf file is:

KEY_GREEN		   0x00007ba3

For me, it would be perfect either way (Green button added to osmc-remote-lircd or double presses not happening on the correct profile).

Many thanks

This may be not at all helpful but if it’s an issue of the green button being recognized but doing something like trying to open PVR, try this:

Change the name of the key. In my case it was KEY_PVR that I changed to KEY_HOME.

The Kodi Keymap Editor can also be very useful in remapping recognized keys to do what you want them to. I got my very finicky remote working perfectly by editing a few things in lircd.conf, Lircmap.xml, and then finishing up in Kodi Keymap Editor.

Thanks, unfortunately the green button does nothing when I press it. However, with the osmc-remote-lircd loaded, pressing the green button produces this in the log:

    07:47:26 T:3023917056   DEBUG: LIRC: Update - NEW at 63924449:e2 0 KEY_MEDIA linux-input-layer (KEY_MEDIA)
07:47:27 T:3023917056   DEBUG: LIRC: Update - NEW at 63924832:e2 0 KEY_MEDIA_UP linux-input-layer (KEY_MEDIA_UP)

I am not sure how to turn this into a KEY_MEDIA statement in the conf file though.


Your key is being recognized, Kodi just doesn’t know what to do with it. I think assigning KEY_MEDIA to some action in ~/.kodi/userdata/Lircmap.xml may fix the issue for you.

You need to identify what part of Lircmap.xml by using irw.
Example from pressing my home button with irw running:

osmc@osmc:~/$ irw
16e 0 KEY_PVR linux-input-layer
16e 0 KEY_PVR_UP linux-input-layer

You can see that lirc is sending KEY_PVR with device linux-input-layer. So under linux-input-layer section in Lircmap.xml I’d need to add KEY_PVR to one of the actions.

1 Like

KEY_MEDIA is also in the linux-input-layer.

I don’t have an Lircmap.xml under userdata. I found one in usr/share/kodi/system and added the line:


Under the linux-input-layer section, rebooted the pi and it worked.

Thank you all for the help, hope this solves it for the OP as well.

Glad it worked. I’d copy your Lircmap.xml file to ~/.kodi/userdata/ if I were you. I think Kodi gives priority to config files in ~/.kodi/.

Yes it does, but more than that - the Lircmap.xml that is in /usr/share/kodi/system will be overwritten next time we send out a Kodi update. (which will be quite soon) You should never edit any files in /usr/share/kodi directly - in most cases it’s possible to either copy the whole file to the appropriate userdata location, or override individual settings.

1 Like

The file has been copied :smiley:

Many thanks