Read only filesystem


will it work in OSMC RC as described here to make the filesystem read only?
Sorry, but my knowledge about Linux is not good enough to evaluate that.


To confirm - works still with RC3 upgraded to 2015.06-1.

Yes! In recent update kernel 4.2.1-1-osmc has CONFIG_OVERLAY_FS=m.
Will you keep it there in further updates? This really makes read-only alternative pretty easy and fast.
Updated version sources in here:

I tried to install the scrip on a clean install of the newest (january) version of OSMC on a Raspi 1 B and got the error message that the addon has the wrong structure.
Downloaded it via the provided link, extracted it and compressed the folder script.rorw to zip.
Then tried to install it from an USB stick and from my NAS via NFS and SMB.
Everytime the same error. I’m on OS X Yosemite.

I sent you priv email, send me the zip you created so I can try it.

I replied to your mail and sent the zip with the mail.
Didn’t you get it?

If you’re using safari turn off the option to automatically extract archives in the safari preferences. Or try a different browser like chrome or Firefox to do the downloading.

I have turned off this annoying feature. I extracted the archive and compressed the script folder with the finders built in compress function.

When I’m at home this afternoon I will try another tool to extract and compress the files.
Maybe OS X is doing something weird with its compress function?

Edit: Tried it with iZip. No success :frowning:

Note the zip created on mac has extra ‘__MACOSX’ content, which might be the problem.
I added ready made addon zip to repo:

Updated following osmc 2018 modifications to the mount system: