Received OSMC wifi-ac adapter - ISSUES


#21

Great news! Please keep us informed if you have more problems.


#22

i spoke too soon. i got a crash, had to do a cold boot (unplug, then power up), and now I get the same behavior. Trying a reinstall of the latest osmc, in case my previous install had been corrupted. I am going to install with the osmc adapter plugged in.


#23

If you have a Windows PC and want to rule out a HW issue, you can try
the dongle on the PC. If it works fine, something Pi related is the issue.

Haven’t had any drivers changes for the device for a while.
There was a ConnMan change but quickly reverted in August.

How are you determining that? What does not ‘picked up’ mean? Does it mean not present under lsusb or something else?

ConnMan will only connect to one technology of the same class at a time.
The preferred technology.

You can manually connect to WiFi, but if you reboot, ConnMan will only bother with Ethernet. I suspect you may have rebooted after picking WiFi. Pull out the Ethernet and ConnMan will quickly switch to WiFi.

Post debug logs. Sounds like an odd one.

None of these issues actually sound related to the adapter. But keep us posted.

Sam


#24

When I say, isn’t picked up, what I mean is that there is a countdown waiting for the network, in order to connect to the mysql database. I assume it’s because wifi did not connect. Maybe the adapter wasn’t recognized or maybe it just didn’t connect.

I’ll try to post debug logs. Is it possible to do that if I boot to a black screen?

I’m reinstalling fresh now, so maybe that will help.

I had previously blacklisted the rpi’s built in drivers, is that necessary with the OSMC adapter?


#25

Yes, it’s necessary when ever you don’t want it to be used. But I would not blacklist it but disable via config.txt


#26

I have isolated it down to only the 5ghz network not working for the PI. Works fine on 2.4GHZ Tried the adapter on Windows10 and it works fine on 5GHZ.


#27

Is your router configured with 2 separate networks for AC and N? Or are your AC and N networks using the same AP name? If so, that may be the problem.


#28

no, my 2.4 ghz and 5ghz networks have separate names. Here’s what i have so far

Windows 10 - adapter works on both 2.4 and 5ghz, gets speeds as expected

Raspberry Pi - Works only on 2.4 (can access internet and LAN). Does not work at all on 5Ghz. Gets an IP address assignment but will not connect to lan or internet – same exact behavior on 2 different RPis with the official Rpi power supply

the 8812au adapter (edimax 7811utc) works on both bands. I assume the new power adapter will solve some of the stability issues with that one.

My router is a TPLINK Archer C8 (ac router). No problems with other AC devices (incl the 8812au mentioned above)


#29

Official RPI adapter is 2.4Ghz only, so I’m
not even sure how you see the 5Ghz network on it.


#30

you sell both an “n” only adapter, and an “n/ac” adapter. wifi ac is 5ghz only


#31

btw, it may have cause confusion when i said adapter, I meant power supply. the 2.4ghz and 5ghz are in reference to the usb wifi adapter…will be clearer in the future


#32

Hmm, you never mentioned that that dongle was also having problems. Sounds to me like you may need to take a look at your router.


#33

i doubt it. the 7811 only had problems occassionally freezing on videos, which everyone told me was related to the power supply. have not experienced that yet with the new power supply. no other wifi ac or 5ghz devices have ever had problem. definitely not the problem


#34

Did you disable the internal Wifi (if it is a Pi3)?
Did you try to set the Country for the Wifi?


#35

I did disable the internal wifi. I did it by blacklisting the driver (not familiar with the config.txt file). Looking into that. I set the language and time zone in the initial setup, but not country for wifi. Do you know where that setting is? Thanks.


#36

add dtoverlay=sdhost to config.txt

Setting the country might not be necessary. For that you would need to install crda and use iw reg set


#37

Tried fzinken’s suggestion of editing the config.txt, and got it working for awhile. When using 5ghz, it connects, then eventually loses connection, and then isn’t able to connect again.

Is anyone using the official OSMC wifi ac adapter on a 5ghz ac network successfully? I’ve tried everything I can think of.


#38

Yes I do run it successfully.
You may want to try to disable background scanning.
But that normally should not make the stick disconnect but just making connection slow every 5 minutes. You would also see it in the log file


#39

fzinken, thank you, I’ll try that. I have also seen at the link below that instead of dtoverlay=sdhost (I realize this is working for you), the correct way to disable wifi is to add -

dtoverlay=pi3-disable-wifi

to config.txt

https://raw.githubusercontent.com/raspberrypi/firmware/master/boot/overlays/README

anyone familiar with this? Thanks.


#40

If I remember correctly my command will disable the WiFi and the Bluetooth