Received OSMC wifi-ac adapter - ISSUES


#107

How would you have two routers in the same subnet?
Whats the output of arp -a?


#108

Ddwrt router is “repeater bridge” mode extending internet box WiFi router which manage dhcp resolution


#109


#110

This confirm connection issue…


#111

everyone is out of ideas?


#112

You have a relatively complicated set-up and, unfortunately, using repeater-bridge mode on DD-WRT has the potential to be flakey. It looks like the X6 uses a fairly “bleeding edge” Broadcom wireless chipset, so issues are a possibility. Also, a quick look at the DD-WRT page for repeater-bridge mode contains the warning:

Repeater Bridge on Broadcom [also Atheros Client Bridge (routed)] is generally not a good solution, as it is not a true bridge

Clearly, we have no way of knowing if this applies to your particular device.

Some further points:

  • Please supply full logs (grab-logs -A).
  • You need to have assigned a channel between the repeater (X6) and the primary router. What is it?
  • Is the OSMC device using a different channel or frequency from the one above?
  • You might see an apparently good signal strength on the Pi, but the hop from the repeater to the primary router might be less than stellar. Signal strength can also seem to be good but throughput can suffer due to other factors such as interference or contention with other devices on the same channel.
  • If you connect the OSMC Pi to the repeater-bridge by cable (without the dongle attached) can you ping other devices on the LAN and/or ping 8.8.8.8? What happens if you then attach the dongle?
  • To which router are the IP addresses from the arp command attached?

#113

As a quick test: can you make a WiFi hotspot on something like your phone and see if you can connect?

Sam


#115

@sam_nazarko hello,

Yes I can connect to internet box, cellphone hotspot, even on my netgear X6 ddwrt if in wifi N mode

If I switch in AC mode, I got weird IP address or right ip but “statut: No Internet”

@dillthedog
ddwrt repeater bridge works pretty well. With AC mode only I get around:
700Mbps txrate with my dell pro laptop
550 => 600Mbps with my iphone7
300 => 350 Mbps with the OSMC USB dongle on windows7
300 => 350 Mbps with the OSMC USB dongle (in ddwrt UI) on OSMC raspberry => but No internet even with right DHCP IP

150Mbps with the OSMC USB dongle (in ddwrt UI) on OSMC raspberry in WIFI N mode

to get 300/350 Mbps I set Wirelessmode = 14 and added key TxRate=14

If We can fix this conenction issue, I think results will amazing with high Txrate like this


#116

Both Tom and I have asked for logs. So please (1) boot the device with only ethernet attached; then (2) attach the dongle; then (3) post logs.


#117

I suspect the power supply could be the issue here. The dongle uses a lot of power and will not work properly unless the device is being powered correctly


#119

Ok i will post logs when I ll be home

@sam_nazarko, USB dongle is plugged to a powered usb hub, I doubt about a power issue


#120

Hello,

So i performed tests on fresh install
1/ attach ethernet and nothing else : logs : https://paste.osmc.tv/isiraqaboz
2/attach ethernet and plug the dongle wifi and try to connect it to my wifi AC network
got error message :
"grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Exception Details:

Traceback (most recent call last):
File “/usr/bin/grab-logs”, line 816, in dispatch_logs
raise ValueError(‘Upload Returned Empty String’)
ValueError: Upload Returned Empty String

Failed to upload log files, copying to /boot instead. (Unable to verify)
"
=> I guess coz it not connected so cant upload?

3/ attach ethernet and just plug the dongle wifi (not trying to connect it to wifi network)
https://paste.osmc.tv/oyufemunez


#121

Capture

My ddwrt settings


#122

Try change the channel

Can you try the dongle directly to Pi?

Sam


#123

Which channel? I tried 36 and 52 in lower lower mode

I tried dongle directly on the pi, same problem


#124

It looks like you’ve forgotten to copy / configure the file /lib/firmware/mt7610u_sta.dat.

Sep 09 14:11:17 chambreparent kernel: RtmpOSFileOpen(): Error 2 opening /lib/firmware/mt7610u_sta.dat
Sep 09 14:11:17 chambreparent kernel: Open file "/lib/firmware/mt7610u_sta.dat" failed (configuration file not absolutely necessary)

#125

Yes it’s fresh install so I didnt execute :
sudo cp /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat
and no edited it


#126

I don’t have one of these dongles but I believe that the WirelessMode needs to be changed for AC to work (mentioned by @Tom_Doyle above) And your router is configured for AC-only.


#127

after cp :
https://paste.osmc.tv/egekihusot


#128

setting wirelessmode=14 and countryCode=FR
https://paste.osmc.tv/uwaxiqawak