Reciever anoyingly jumping back to Vero 4k input

I just 2 days ago reluctantly bought an Apple Tv 4k mainly to get Atmos in Netflix.

I finished setting up my Harmony macro and it starts the tv (samsung q9fn), reciever (Yamaha 3060), ATV and everything worked fine.

I aldo have a macro to switch to the Vero 4k and have used it for a long time and the vero is always on in the background.

So yesterday i chose to start the “watch apple tv” -macro and everything starts but at the end the reciever jumps back to the vero and displays my movies etc. Even if I change the hdmi-port back to the ATV (ATV is on av3 and vero is on av1) it just jumps back to the vero so its impossible for me to watch the ATV.

I went into the vero settings and turned off cec and it looked like it was working yesterday but today when I was showing my wife how to start and operate the ATV the same thing happened, it just changed back to vero all the time no matter what, and it did it so fast i could never even see the display of the ATV. I had to turn off the vero to be able to change to the ATV hdmi and have it stay there.

Anyone had the same problem and a solution? Is it something with av1 (hdmi1) that makes it king of the heap and a change to hdmi2 would help?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Are you sure logs will help? The vero will stay still and not move a muscle in the background, it is the hdmi ports that are switching. The vero is also working perfectly fine, it is just hijacking my reciever.


The logs should report something like hdmi switch detected, its possible it may give some insight as to why the TV is switching to the vero4ks input.

Thanks Tom.

Ok I cant seem to reproduce it now, I think maybe the ATV has to be switched off for a longer time or something. It was like the tv couldnt lock onto the signal and that made it try something else (going to a port that has something on) since when it happens i never even get to see the ATV homescreen before it switches back.

I will look out for when this happens next time and enable logging. It will switch to the vero and then i suppose I can enable logs and then do the hdmi-switch dance a coupple of times and then upload that?

1 Like

Yes – but a reboot after enabling logs would be ideal to trim them.

I will do that.

In the meantime, hypothetically - if i feel i want cec should it then be “on” on all my devices or could mixing ond and off devices eff things up?

You only need to enable it for the devices you want to use CEC on


1 Like

Exactly the same thing happened to me when I bought an ATV 4K a few months ago (I have a Marantz AVR). Within seconds of switching to the ATV, the Marantz would switch back to the Vero. My son told me it would occasionally happen with the PS4 as well. Nothing I could find in the Vero’s CEC settings could stop it. In the end, I disabled CEC on the Vero and it’s been ok since then, and I rely now on the iOS Kodi remote app and the Vero’s physical remote.

With my Arcam receiver and LG TV I need to either enable CEC on all devices or disable them on all devices. If I disable it on one or more devices the other devices will constantly wake up the receiver and in turn the TV.