Remote control configuraiton OSMC

Can someone help with configuring HP remote control on OSMS for Rasberry Pi?

Could you be a bit more specific what you mean with HP remote control? Are you refering to a remote sold by HP with their PC’s that you want to use or are you referring to “HP Insight Control”?

Please provide exactly what your are trying to do.

Yes, thanks for responding. It only says HP on the 2"x5" black remote control.See attached image

. It came with the Rasberry Pi. I installed OSMC on the PI but the Remote Control does not work with OSMC like it did with when the Rasberry PI when it had XBMC. Thanks1

Did it also come with an IR receiver? Because without that, the remote is probably no better than a paper weight.

No it did not come with an IR receiver. Was told that was in the Pi.

Yep, there is a Raspberry Pi kit which comes bundled for media (from CrispConcepts) with the IR receiver and the HP remote. When the RPi had XBMC installed, the remote/IR receiver worked fine after the install, no extra set-up was necessary. After the OSMC install, the remote does not work. It may need some extra steps to get this particular remote and IR receiver to work with OSMC. Any help with this would be greatly appreciated. Cheers.

How many ppl have an issue here? If hbidawi has no receiver, then one must be acquired. If receiver is present, you can probably use the remote config module in MyOSMC to select the appropriate remote (quite probably rc6? Not a remote guy myself) and reboot then test for function.

The IR receiver was already installed when you got the kit. Otherwise the remote would have never worked. Since the remote worked when XBMC was installed in the RPi originally, then you would assume that the issue is not with the remote or the IR receiver.
Please try ActionA’s suggestion and reboot after each selection to test the new settings. Do this with each remote option until one of them works. You still will need to reboot after each new selection just to be safe.
Good luck.

The above seems to indicate that is an MCE remote, not RC6.

If you do not have an IR receiver you can add on to the GPIO pins on your Raspberry pi, all it takes is an IR sensor, 3 wires and 3 pin of your GPIO.
Pin 2 of GPIO is 5v
Pin 6 of GPIO is Gnd
Pin 12 of GPIO is GPIO18
Refer to video here for step by step guide: How To Make An Infrared Sensor For Raspberry Pi GPIO - YouTube

As for the remote go get a cheap xbox 360 dvd remote, on your osmc go into my osmc menu then remotes and select the xbox 360 remote.

Done, Should be good to go.

Thanks a lot. I still do not understand why this bloody HP remote worked on Rasberry PI and XBMC and does not with the same Rasberry PI on OSMC. I did not have to do any wiring for th remote after the XBMC was installed. It seems that an OSMC drive/script/config file is missing because it is definitely not a hardware issue. The hardware is exactly the same. Appreciate your response…

That should be a MCE RC6 remote, select the profile in MyOsmc>remotes and see if it works

My bad for the delay. I tried the RC6 config file and rebooted with no success. I have the mini HP remote. Thanks!

I would also like to know how to get this remote to work. My remote looks exactly as the one pictured accept for the home (mce green) button. The model #RC2234302/01B. I have tried downloading the file from lirc remote archive and it doesn’t work either. Also tried to make a irrecord .conf file by ssh to raspi. It records gives me the constant length: 127634, but when I get to the second line of button pushing it slows down and stops making dots completely. Then it times out when I stop pushing them. I have gotten it to make some responses but not very well with making my own config file. Probably because I can’t get through the second line of button pushes.