Remote dont working

I have a Vero 4k+ with the original RF remote control.
I am not sure if it’s related to the latest update (I think not), but the remote control suddenly stopped working. I tried reconnecting the dongle, cold reset, hard reset,replace battery,and a reinstall OSMC from the download page still not working.
Any way to debug this?


  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

i have it down no flash no bluelight on the remote it is dead i have try everything.

The battery is probably dead. Did you verify that the battery you changed is new and is not dead?

yes it is a new one and it doing nothing no flash a have try everything and it is dead.

Sorry to hear that. You can start a support request for RMA.