Remote issue. Yatse specifically


First time poster hoping for a bit of help. I’ve searched the forums but not found an answer to my issue.

I’ve been using the Yatse remote without issue for the last two weeks. I rebooted my router last night and have been struggling to get the remote to connect since. I’ve not changed any settings in OSMC since the router was rebooted and I’m able to control OSMC via a browser on the same network.

I’ve had some limited success in getting Yatse to connect after a reboot of OSMC but it disconnects after a few minutes and I am scratching my head as to what the issue is. The remote is failing the JSON-RPC test.

I was using Raspbmc previously and I am very glad I have made the upgrade.

Thanks in advance and for all the work that has gone into Raspbmc and OSMC,

So the only thing that has changed is the router has been reboot?

Have you updated OSMC recently?

I only upgraded to osmc two weeks ago so I have the latest build. Only thing that has changed is the rebooted router.

Have you run an update from My OSMC?
A lot of stuff has been changed and updated under the hood since Alpha 4 was released.

Just ran the update but the result was the same. After the pi rebooted, yatse connected then disconnected within a few minutes.

Clear the Yatse cache and data, then re-add the kodi box.

Follow this and make sure everything is configured properly.

@CaNsA, cleared the cache and data, still no joy. Also tried uninstalling and re-installing the app but that didn’t work either.

@ActionA, I’ve seen that thread before and I’ve followed it to the letter before, I’ve done it again to double check but it hasn’t resolved the issue. The options it advises to select were not required for the app to work previously and from reading other threads the requirement to allow programs on other systems shouldn’t be required for Yatse to work. Either way none of the suggestions have had any effect.

I appreciate your help.

1 Like