Remote - key mapping

I have Logitech Utrax remote with usb receiver. Problem is Enter key doesn’t work, instead I have to use OK key which is not convenient.
Key are recognized by irw as:

1c 0 KEY_ENTER linux-input-layer
1c 0 KEY_ENTER_UP linux-input-layer
160 0 KEY_OK linux-input-layer
160 0 KEY_OK_UP linux-input-layer

How can I map KEY_ENTER to have same function as KEY_OK? Already tried adding following to Lircmap.xml:


but that didn’t work.

Have a look at this wiki page
and decide whether you need to ask more questions.

Are you using a lircd.conf file (selected in the remotes section of OSMC settings) or did it “just work” when you plugged it in ?

The answer to that question determines where the best place to alter the button mappings is…

It worked “out of box” (minus mentioned key). Selecting different remote in OSMC settings doesn’t make any difference, perhaps my remote isn’t detected as remote after all?

edit: somehow my first post got messed up, Lircmap.xml looks like:


but it still doesn’t work.

Try using this:

It’s a fantastic addon I just found tonight when I had issues with changing my remote.xml file. What took nearly five hours of research and mucking around I could have done in 5-10min with this app.

It overrides all previous settings you created but keeps them safe as a backup. You select what function you want a key to have and it then asks you what key you want that function to be taken care of.

@sam_nazarko I hope something like this will hit osmc soon! I don’t want to edit xml files.
:expressionless: XML :expressionless:

JSON to XML parser it is

Seriously though, I have ‘remote learning’ in mind for future.


1 Like