Remote not working

The V4K remote stopped working today after I rebooted the device. I tried the stuff listed in this thread Remote not working after May 2017 update but to no avail.



I’m on the latest update as well (5-2)

The thread’s advice is for infrared remotes.

Just to confirm, you’re talking about the official, included RF remote?

Do you see a blue light on the OSMC remote when you press a button? Have you tried changing the battery?


Yes, it has a blue light. I’ll try changing the battery though and see if that works out.

Just want to share how i resolved my remote stopped responding. I just plug the receiver into my windows laptop and after it auto installed the driver and is responding, i plug the receiver back to the vero4k and it works again.

Also my remote stopped working.
Tried the above trick doesn’t work, since after driver installation on win 7 pc nothing moves while you press any key in the remote.
The same when I’ve replugged the receiver on V4K the remote DOESN’T work.
The blue light on the remote lightup each time you press a key.
This Vero4k purchase seems an Odissey, very very very disappointing.
No solutions from support ?

Hi – I’m sorry to hear you’re having a problem with the remote.

I couldn’t find a post or email from you reporting this problem before, so this is indeed the first time we’re responding to your issue here.

Is the blue light slow or fast on the remote?
Can you insert the dongle and upload a set of logs via My OSMC?

Failing that, we’ll happily get this swapped over for you



I’ve bought V4K around 1 months ago and i use it by a couple of weeks.
The blue light lightup immediately when you press a key
Without remote I’ve no idea about how can I interact with this object… ssh maybe?


If the remote is faulty, we will swap it over for you.

It sounds like the dongle is bad. If you ping with a link to this email we can
take care of this for you promptly.

In the interim, you can control the device using CEC or a smart phone application. You can also control it from a web browser if you have the IP address of the device (check the router).



Also: can you confirm that you tried to re-pair the remote as follows:

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.


I have the same problem on my Vero 2. The remote control dongle is not recognized by the Vero and the remote has a ‘long’ (~0.5s) flash when a button is pressed. The remote worked fine previously.

I have tried re-pairing as above and have changed the battery. Both with no joy. The dongle is in the port next to the audio port.

Any suggestions?



Have you tried to repair it when plugged into a PC?

My desktop runs Ubuntu, and the dongle is not recognised there either (ie missing from lsusb).

That is strange, csan you check dmesg after you plug it in? Yo shoudl see something like

[29874.073583] usb 3-2: new low-speed USB device number 6 using xhci_hcd
[29874.265829] usb 3-2: New USB device found, idVendor=2252, idProduct=1037
[29874.265837] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[29874.265842] usb 3-2: Product: USB Keyboard Mouse
[29874.265846] usb 3-2: Manufacturer: HBGIC Technology Co., Ltd.
[29874.271338] input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/0003:2252:1037.0007/input/input31

Nothing in dmesg at all. As though I hadn’t plugged it in.

That would indicate that the USB dongle is having an issue. Might be @sam_nazarko has some rescue idea but sounds like a dead device


Oh well, thanks @fzinken for your prompt help. @sam_nazarko any ideas?

OK, I’ve given up waiting for an answer and will have to fork out the seventeen quid for a new one…

It doesn’t hurt to knock on Sam’s door one more @sam_nazarko it always could be he was busy at that time

If your device is faulty, email

Thanks, I have done so