Remote region seems off

I’m using an iClever French AZERTY remote and I definitely have that set up in the settings but when I go to type to do a manual subtitle search, it’s like it only takes my remote as a QWERTY remote. Where is the setting or string I need to edit to fix this?

Thanks!

There are plenty of threads on this subject, please use the search function built into our forum…

https://discourse.osmc.tv/search?q=french%20azerty

Knock yourself out, here’s some more Search results for 'keyboard' - OSMC Forums