I’ve been using a raspberry Pi 1 model B for over 5 years now.
Pi is linked to a yamaha amplifier/av receiver (rx-v567), on which is plugged my videoprojector.

To control all fo that, I use the logitech harmony 700 remote.

I control OSMC with an usb ir receiver, and the harmony remote is set as a WMC remote.

With the latest version of OSMC, the remote doesn’t work, though the usb receiver seems to receive the remote signal’s (little light turns on when I press the keys).

I’m wondering what to do next.
I’ve been wondering about buying the Raspberry 2, to upgrade my setting.
Should I look into a fix for my usb IR receiver? Or with the latest versions of OSMC, should I look into a GPIO ir receiver?

Thanks !

Have a search. We changed the way remotes work in the last update

I’ve tried a search and don’t find anything but old topics… :frowning:

Just go to myOSMC -> remote and choose the respective profile.
If that doesn’t solve you problem then provide debugging logs

I’ll try that !

I had the same issue, & chose the profile, so my harmony logic 650 remote is now picking up button presses but it constantly seems to be registering multiple presses. The old way the remote worked never did this. Any way I can get the old way back

I’ve set the remote in myOSMC, and the remote seems to be working.

Although, some keys don’t work anymore. I have “back” key that I used to go back to previous in menus that doesn’t work anymore.
I’ve tried using the extension “keymap editor”, but couldn’t reprogram that key.
Any idea why?

Just re-enable the internal RC6 decoder and symlink the LIRC config to /dev/null.

that looks like chineese to me… :smiley: I’m a linux noob…
How do I re-enable the rc6 decoder and symlink the lirc config?

Thanks ! :slight_smile:

Do a forum search for “RC6”

It’s working perfectly now !
Thanks !