[REOPENED] HDMI CEC generates random double press after February 2016 update on Vero

After the upgrade I get double presses sometimes, not always. It might be if I press the button longer, but I’m not sure.

Can the sensitivity for the length of the press be adjusted?

You should be able to configure repeats in Kodi now


1 Like

Check in settings->System->Input Devices->Perihperals->CEC, at the bottom of the list are some new repeat options.

1 Like

Thanks - it got a bit better but still double presses roughly every fifth press.

We’ll look at this. Do you have a Pi? Is it any different?


what settings did you try?
I’d suggest “delay before repeating” = 500, “repeat rate” = 100, “release time” = 0.


Thanks @popcornmix, that setting seems to work!

I tried delay before from 500 up to 1000, but didn’t change repeat rate. When I tried your settings I haven’t seen a single double click.

@sam_nazarko: I have a pi2 but only connected to an old TV without cec. So I’m happy that I didn’t have to dig it up and try it in the living room :grinning:

February update broke this on my Vero :frowning:
I can’t find the double press settings anymore.


The patch for this was missed when I rebased to Jarvis.

I have re-added it:

I am rebuilding Kodi and when that is done you will receive notification of an update which will restore this option.

Thanks to @popcornmix for the original patch

1 Like

The patch is included again, you can update via My OSMC and the menu should re-appear.


1 Like

Updated and re-entered @popcornmix suggested values in the thread - seems to work like before. :+1:

One minor glitch: when entering a value in the GUI it is prepended with a minus sign in the selector popup. @sam_nazarko

Settings get reset on reboot:

This may be an issue with guisettings.xml. Jarvis has been a bit problematic for some users

Can you try

sudo systemctl mediacenter stop
mv /home/osmc/.kodi/userdata/guisettings.xml /home/osmc/guisettings.xml.bak
sudo systemctl mediacenter start

You will need to configure your settings again but hopefully things will stick



  sudo systemctl stop mediacenter
  moved file
  sudo systemctl start mediacenter

This did not help - value still gets reset after reboot :frowning:

I don’t get the defaults - 500 - 0 - 500, because in peripherals.xml the defaults are 300 - 0- 0, so were does the default value after reboot come from?

@popcornmix Any idea as to why the settings doesn’t seem to stick in Jarvis? Anything changed in how they retrieve/store the values from file?

There has always been a bug where you can only change CEC settings once per boot. Are you hitting that?
Reboot. Change CEC settings. Reboot - did the change stick?

Nope, that’s not it. This is new since Jarvis on Vero.

Set values to 500 - 100 - 0 as per your suggestion in this thread.
Values are reset to 500 - 0- 500

As per @sam_nazarko’s suggestion this is with a freshly created guisettings.xml

Try and set it via the Confluence skin
Try uploading a log if it persists

Same behaviour with confluence.

Log after setting the values manually after reboot:


I’m not sure why this setting isn’t persistent.

I’ll see if I can replicate it here.