[resolved] Kodi GUI freezing after TV/AVR source change or while using (July Update)

Right, the times that I observed freezing during usage was while I was pressing buttons/navigating the menu.
Which devices do you guys have? I got an Onkyo AVR and a Sony TV.

Philips with no AV receiver. Any news on this? The WAF is dropping pretty fast atm.

August update didn’t make a difference unfortunately :frowning:
Could we maybe get an update if you have been able to look into it or been busy with other topics @sam_nazarko?

Thanks!

Hi

I am not aware of the issue here but I am aware of another cause for a freeze that may be related. Will keep you updated as always

Sam

I turned off CEC completely but to no avail, still freezing up after a while. :frowning:

Hmmm… how about additional applications? Have you installed anything besides OSMC?
I manually installed SABnzbd, Sonarr and CouchPotato - maybe the issues lies somewhere there?

I’m experiencing this issue also @sam_nazarko. Normaly while navigating in the VERO’s file system to start a video file. I’m on the August update. The GUI freezes, neither the CEC remote nor the VERO’s remote work. I have to ssh to the VERO and issue a reboot command.
I have a Sony TV, and the VERO is connected via spdiff to a DENON receiver.

Same setup and same problem…

More information on this issue.

The GUI also freezes, quite frequently, when:

  • Navigating the system menus to configure the skin. Yesterday I changed the VERO’s skin to MIMIC, and it took me about 10 reboots to conclude the skin’s configuration;
  • Importing Audio Music files to the VERO’s library. I have around 22.000 music files, spread on around 1500 albums, and to import these files into the VERO’s library, it’s been hard with all the freezes.

How can I help you @sam_nazarko, and your peers, to track the source of these constant freezes?

We are still trying to work out the exact cause. We have got logs of the freeze

Sam

Good morning,

We have had some positive results today and we are refining things and hoping to get out a fix for the freezes shortly. As soon as we are happy with things we will push these changes.

Cheers

Sam

3 Likes

Alright, that’s good news! Thanks for the update!

The fix has been pushed to release and you can grab this via My OSMC

Sam

I downloaded and installed the patch and this morning the usual freeze did not happen :smile:
Can you tell us what caused it ?

Thank you in advance

About 24 hours and no problem so far - looking good :slight_smile: thanks for your support!

The issue really seems to have been resolved with that latest update :slight_smile: Thanks again for your support!

I’m not so sure that problem has been solved.

I’ve a fresh OSMC installation and it is upgraded.
Last night i went to bed and let OSMC be turned on at OSMC main screen. After some while main screen faded down.
To day, there was no contact with OSMC by my Bluetooth keyboard / mouse and i could not wake up OSMC.
At the same time my Wifi-dongle was shutdown.
To me it seems as USB-port has shutdown the power. I tried to pull out and push in the sticks, but that did not wake up USB-Ports.
So i ended up with Power off / Power on to make OSMC running again.
This setup is running on Pi2.
The same hardware setup has been running with Raspbian Wheezy with no trouble at all, except from Wifi-dongle must be forced not to go at Low-Power-Mode, to ensure network at all time.

Hi

This thread about is a completely different issue affecting Vero users.

I would suggest starting a new thread. Your issue is indeed likely to be power management related, but a log will help see what’s going on

Sam

Hi everyone!

This problem occur again! I didn’t have any problem when I was changing TV/AVR sources and after one of the latest updates, I have this same problem which was described in this topic. Each time when I switch between TV and USB device I have to restart osmc to have remote.

My TV and Remote:
Samsung

OSMC:
NOTICE: Starting Kodi (16.1). Platform: Linux ARM (Thumb) 32-bit
NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
NOTICE: Kodi compiled Oct 29 2016 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.36 (200740)

You are posting in a thread that was resolved one year ago and that was related to Vero. Suggest you start a new thread with full debug logs

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request