Return To Menu When Video Stopped

Hello, hoping someone can help out a pretty new newb…I’ve got two questions on a setup that I’m trying to get going for my mom. She’s pretty old, so I’m trying to make everything as simple as possible for her to do one thing only: Watch downloaded media.

  1. When you watch a video and push stop, the screen goes blank. You have to select “back” to return to the osmc interface. Is there any way to make this happen automatically?

  2. When you watch a video and select “back”, the audio continues to play, but the osmc interface is displayed for you to work with. I think this ties in with my first question, is there any way to set it to pause or stop the video when you return to the osmc interface?

I’d like to offer props to the developers and volunteers that have made this so awesome! And in case this is covered elsewhere, I’m sorry, I DID try my hardest to find an answer.


Your point 1 suggests that you are having an issue - because pressing stop should take you back to the previous screen you were on - it will never just leave you on a blank screen, and I have never seen this occur before.

Which skin are you using ? Do you get the same issue on another skin ?

Huh…An Issue…That would explain why I can’t find the setting to fix it!

Ok…I’m gonna have to see what I can do to fix it then…I have experienced this issue using Amber, Confluence and the default OSMC skin. Leaving me to believe it is an underlying issue.

I have tried playing media from a network drive and from an attached thumbdrive. Same issue: when you press stop, the video and audio cease, but it does not return to a menu unless you press "back. I have left it for a few minutes to see if it would eventually decide to load a menu with no result.

Additional info: it happens when playing numerous different types of video files. I have updated the osmc to the latest.

I’m willing to just reinstall the sd image unless you guys want any information for your purposes.


Re. Point 1. Were you watching a DVD?

Negative. I am watching video files from either an attached thumbdrive or from a harddrive accessed through my network.

points of info: have tried .mkv, .mp4, .avi with consistent issue. Using a raspberry pi2 model b. downloaded the osmc image about two weeks ago.

Anything else you would like to know?


Well, reinstalled the sd image and it seemed to work. So that issue was resolved, but now I get a blank screen and no audio for 2 secs when I first start playing a video.

Have a look at the pause on frameratechange options. I think 2000 ms is the maximum. Maybe you hit back by accident.