Rollback December update

Is there an easy way to rollback the last December update? I’m using RetroPie and didn’t realize it wasn’t supported until after it updated. I know I could always reformat my card and start fresh but I’d rather not have to reinstall everything if possible.

No. Unless you have a full image backup you will have to reinstall. Your settings for kodi in /home/osmc/.kodi will be compatible though.

Assuming you mean RetrOSMC, did you try to recompile it?

I looked into that but the RetroPie forums clearly state that it’s not supported yet and I didn’t want to go down that rabbit hole.

@mcobit what’s your view on this?

I am sorry, but I do not have any access to an osmc box until next week.

From what I gathered from github comments, it might be as easy as creating a symlink for the old boost datetime library pointing to the new one or installing the 1.55 version specifically.
I guess that this hapened when switching to stretch and if this is not supported by retropie, there might be other errors , too we did not encounter yet.

As said, I cannot test anything until next week.
If someone wants to try the symlink approach or putting the old lib into the folder with the executable and adjust LD_LIBRARY_PATH before I get the chance, by all means, try it.

No worries, just was surprised not have seen anything on the stretch testing thread on this issue. Seems none of the retrosmc users joined the testing

Yes. That includes me unfortunately.
I just don’t have the time I need to concentrate on osmc or retrosmc right now.

No worries, was just suprized. Maybe it is just time to wait for Leia which should solve a majority of this.

I ended up just backing up my settings and ROMs and rebuilding it with the October release.
Thanks for everyone’s help.

I’m having the same issue. I’d be happy to try @mcobit’s possible fix but I’m a bit of a Linux n00b, so if someone could point me in the right direction in terms of "download this and place it in the folder located here and adjust the path located in this file I should be able to do it and I’ll report back the results.

Hi! @mcobit’s fix is not working I just created the symbolic links to some of the libboost libraries (you have to create 3-4 links) but at the end I ended getting the following error:

/opt/retropie/supplementary/emulationstation/emulationstation: symbol lookup error: /opt/retropie/supplementary/emulationstation/emulationstation: undefined symbol: _ZNK5boost6locale9generator8generateERKSs

and I don’t know how to continue…

Does anyone has an idea?


You can try to put the boost libraries from jessie into some folder and adjust LD_LIBRARY_PATH before starting es.
Or compile and install boost 1.55 manually.

But as far as I know, the problem I have now is not related to the Boost libraries, so I don’t know whether this would help. Anyway, thanks!!!

I think the best option is to buy another Micro SD card and use it with a Retropie image…


There is an undefined symbol in one of the libraries es uses I would guess. That could be boost or anything else.

Another thing to try is to reinstall everything. It could be that a recompilation of es fixes the problem, too.

Same issue here, even tried a fresh install of OSMC, still no luck… I am a total n00b, but willing to help with retrosmc

If you want to do a new install, you have to comment out the stretch-warning in the retropie-setup script for now and implement the workaround found on github or the main retrosmc thread here. We are working on a solution. But it might take some time