Rpi 1 + iPhone 6 + official bluetooth dongle does not work

I’ve not found any official information about this, so I apologize if this was discussed before elsewhere.

I have the latest OSMC fresh install (2018-01-1) on my RPi 1, using the official OSMC bluetooth dongle I’ve bought recently and an iPhone 6 running iOs 11.2.5.

Pairing from the GUI never worked: The phone is discovered, shown on the list but when I pair and enter a pin code in OSMC then the pairing process fails and my iPhone does not ask for the pin code.

So I used Bluetoothctl from command line on earlier version (forgot which one), and that worked. Until now, that i have a fresh new install.

Bluetoothctl starts and I find the iPhone but pairing just does not work.
Is there a bug which renders even the official dongle to work correctly and I should stop experimenting for a while?

[CHG] Device 64:9A:BE:A1:89:F5 RSSI: 39
[Somez’s iPhone]# info 64:9A:BE:A1:89:F5
Device 64:9A:BE:A1:89:F5
Name: Somez’s iPhone
Alias: Somez’s iPhone
Class: 0x7a020c
Icon: phone
Paired: no
Trusted: yes
Blocked: no
Connected: yes
LegacyPairing: yes

[Somez’s iPhone]# pair 64:9A:BE:A1:89:F5
Attempting to pair with 64:9A:BE:A1:89:F5
Failed to pair: org.bluez.Error.AuthenticationFailed

I might recall succeeding earlier by initiating the pairing form the iPhone and making it a trusted through bluetoothctl. However osmc is not shown on the list of BT devices on my iPhone anymore. I don’t know why.
It’s set to discoverable mode…

I appreciate your help.

Thank you.

Did you install the A2DP package?

No. I thought that’s part of the default installation. Let me do it now.

Should the pairing work from the GUI with an iOS device?

If you install A2DP, yes.
But A2DP is experimental and isn’t working properly since Debian Stretch. This is being worked on.

Package is a2dp-app-osmc?

Thanks Sam.


Well, I was somehow able to pair using bluetoothctl (doing it form the GUI just doesn’t work, no matter how hard I try). OSMC still does not show up as a target device when playing music on my iPhone and it disconnects after 1-2 minutes on it’s own.

Sam, if you say this is the best it can do, then I give up for now and wait for the next update.
Thank you.