RPi 2 buffering issues since June update

Hello,

I am using Raspberry Pi 2 with OSMC on an 8GB SD card and a WiFi dongle to stream videos from my PC.

At the very beginning, I had some performance issues (buffering etc.), which were resolved after I set my advancedsettings.xml file as follows, according to some recommendations I found here):

<advancedsettings>
 <network>
  <buffermode>1</buffermode> <!-- Comment: Default is 1 -->
  <cachemembuffersize>0</cachemembuffersize> <!-- Comment: Default is 20971520 bytes or 20 MB -->
  <readbufferfactor>4.0</readbufferfactor> <!-- Comment: Default is 1.0 -->
 </network>
</advancedsettings>

Everything worked fine for a good few months, until a few days ago I believe I received the June update. Now I can’t watch anything. Kodi just buffers and buffers… then plays a few seconds and buffers again.

I made sure the settings file is intact and also cleared the temp director that was really huge for some reason (update leftovers?). These steps did not help, so I am quite frustrated :frowning:

Any ideas?

Thank you,
Shawn

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Silly me, I forgot to add the link. Sorry!
OSMC log

A cachemembuffersize of 0 is not recommended on a Pi - this tells Kodi to use a disk based buffer instead of storing it in ram. This buffer will be saved on the SD card, and some SD card’s have very slow write performance so this will become a bottleneck, as everything you stream has to first be written to the SD card buffer file then read back from it.

Depending on how much free space there is on the SD card and the quality of the card the write performance may degrade over time as the card is used, especially if it is doing a lot of writes. Using the disk as a buffer will also wear the card out a lot faster.

I’d change the buffer size back to the default first and see if you still have a problem. Leave buffermode and readbufferfactor how you have them.

Unfortunately that did not help.

If you are experiencing buffering when using 3rd party addons that will not be supported here, you can be reasonably certain that the issue causing the buffering is poor performance of the servers that provide the content, not OSMC/Kodi. Since your debug logs don’t demonstrate any attempts to play content that buffers from any source, we have no idea how to further help you.

As I mentioned, I stream movies from my PC and not using any 3rd party addons for that. I use an SMB share on my Windows PC.
As I also mentioned, everything worked fine before the June update.
Hopefully you will have some suggestions.

I installed a fresh copy of the latest version of OSMC, just ion case.
Tried both advancedsettings.xml with cachemembuffersize=0 and with the default value.
The results are the same. At some point, the video stream freezes and buffers for a very long time. When displaying the codec info overlay I noticed the percentage of errors syncing is 98%-100%. When the video stream normally, it’s on a constant 25% (is that OK?..).

I remind you I stream the videos using the default Kodi player (not using any addon) from my PC over WiFi. The WiFi network has no other special activity on it.

Here are the full logs:
http://paste.osmc.io/obevuledur

Thanks again.

Does temporarily trying a wired connection to a wired switch/router resolve the issue?

I have a similar, possibly related problem. TryIng to watch bbc Olympics coverage on iplayer

Works fine on my laptop via wifi but buffers every few seconds on the rpi3 on the same wifi. Using the inbuilt rpi3 wifi adapter. Much better but not perfect on rpi ethernet would an external wifi adapter help, or tweaking buffer sizes, or is it asking too much of the pi3?

Hard to pin the exact issue here, but seems like you may have limited WiFi reception here.

I am not trying to stream on both machines at the same time.

BBC iplayer streams that buffer continually on my pi3 will play flawlessy on my laptop over the same wifi, which I guess means the wifi/router/isp connection to iplayer is not the problem, it looks like the pi3 needs bigger buffers, or the iplayer addon can’t cope, or the pi3 simply isn’t fast enough.