RPi LIRC Issue Nov Update

Hi, Installed the November 20 Update (from Oct 20) and now the IR remote has stopped working - it was previously working fine

OSMC Nov 20, RPi2, RC6-MCE remote, TSOP4838 gpio pin18

Does anyone else have an IR issue with this update? Thanks

From which version did you upgrade?

Some logs would be useful.

It was from a fresh install of Oct 20, I will post the logs shortly. Thanks

Same Problem. Update from Oct. 2020 to Nov 2020
Have a nice day, Ernesto

Addendum: I have restored the backup of the October version, now everything works fine again

My Logs

https://paste.osmc.tv/sawutipomu

Thanks

root@osmc:/home/osmc# more //boot/config.txt 
gpu_mem_1024=256  
hdmi_ignore_cec_init=1  
disable_overscan=1
start_x=1  
disable_splash=1
gpu_mem_256=112  
sdtv_aspect=1  
gpu_mem_512=144  
arm_freq=1400  
core_freq=400  
sdram_freq=400  
max_usb_current=1

dtoverlay=gpio-ir,gpio_pin=18
root@osmc:/home/osmc# dmesg |grep lirc
root@osmc:/home/osmc# journalctl |grep lirc
Nov 26 10:37:01 osmc log2ram[202]: lircd
Nov 26 10:37:03 osmc systemd[1]: Starting eventlircd remote support...
Nov 26 10:37:03 osmc systemd[1]: Started eventlircd remote support.
Nov 26 10:37:07 osmc sudo[557]:     root : TTY=unknown ; PWD=/ ; USER=osmc ; ENV=LIRC_SOCKET_PATH=/var/run/lirc/lircd ; COMMAND=/usr/lib/kodi/kodi.bin --standalone -fs
root@osmc:/home/osmc# ir-ctl -f
/dev/lirc0: cannot open: Datei oder Verzeichnis nicht gefunden
root@osmc:/home/osmc# lsmod |grep lirc
root@osmc:/home/osmc# 
root@osmc:/home/osmc# uname -a
Linux osmc 4.19.122-2-osmc #1 SMP PREEMPT Sat Jul 4 02:39:56 UTC 2020 armv7l GNU/Linux
root@osmc:/home/osmc# ps auxwww |grep lirc
root       313  0.0  0.0   1932   596 ?        Ss   10:37   0:00 /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd -f
root       557  0.0  0.3   9684  2856 ?        S    10:37   0:00 sudo -u osmc LIRC_SOCKET_PATH=/var/run/lirc/lircd /usr/lib/kodi/kodi.bin --standalone -fs
root      1076  0.0  0.0   6828   596 pts/0    S+   11:00   0:00 grep lirc
root@osmc:/home/osmc# systemctl status eventlircd.service
● eventlircd.service - eventlircd remote support
   Loaded: loaded (/lib/systemd/system/eventlircd.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2020-11-26 10:37:03 CET; 24min ago
  Process: 249 ExecStartPre=/bin/mkdir -p /var/run/lirc (code=exited, status=0/SUCCESS)
  Process: 314 ExecStartPost=/bin/sh -c for f in /var/run/lirc/lircd-*.sh; do if [ -e $f ]; then s=$(basename $f .sh | sed 's/lircd-//g'); systemctl start 
 Main PID: 313 (eventlircd)
   Memory: 404.0K
   CGroup: /system.slice/eventlircd.service
           └─313 /usr/sbin/eventlircd --evmap=/etc/eventlircd.d --socket=/var/run/lirc/lircd -f

Nov 26 10:37:03 osmc systemd[1]: Starting eventlircd remote support...
Nov 26 10:37:03 osmc systemd[1]: Started eventlircd remote support.

What’s the output of lirc-lsplugins | paste-log ?

root@osmc:/home/osmc# lirc-lsplugins | paste-log
https://paste.osmc.tv/omequnopiz
root@osmc:/home/osmc# lirc-lsplugins
# Driver            Flags Plugin
accent              ---   /usr/lib/lirc/plugins/accent.so
atilibusb           ---   /usr/lib/lirc/plugins/atilibusb.so
atwf83              ---   /usr/lib/lirc/plugins/atwf83.so
awlibusb            ---   /usr/lib/lirc/plugins/awlibusb.so
bte                 ---   /usr/lib/lirc/plugins/bte.so
commandir           -as   /usr/lib/lirc/plugins/commandir.so
creative            ---   /usr/lib/lirc/plugins/creative.so
creative_infracd    ---   /usr/lib/lirc/plugins/creative_infracd.so
default             ---   /usr/lib/lirc/plugins/default.so
devinput            ---   /usr/lib/lirc/plugins/devinput.so
dfclibusb           ---   /usr/lib/lirc/plugins/dfclibusb.so
ea65                ---   /usr/lib/lirc/plugins/ea65.so
file                -as   /usr/lib/lirc/plugins/file.so
girs                -as   /usr/lib/lirc/plugins/girs.so
asusdh              ---   /usr/lib/lirc/plugins/hiddev.so
bw6130              ---   /usr/lib/lirc/plugins/hiddev.so
dvico               ---   /usr/lib/lirc/plugins/hiddev.so
macmini             ---   /usr/lib/lirc/plugins/hiddev.so
samsung             ---   /usr/lib/lirc/plugins/hiddev.so
sb0540              ---   /usr/lib/lirc/plugins/hiddev.so
sonyir              ---   /usr/lib/lirc/plugins/hiddev.so
irlink              -a-   /usr/lib/lirc/plugins/irlink.so
irtoy               -as   /usr/lib/lirc/plugins/irtoy.so
livedrive_midi      ---   /usr/lib/lirc/plugins/livedrive_midi.so
livedrive_seq       ---   /usr/lib/lirc/plugins/livedrive_seq.so
logitech            ---   /usr/lib/lirc/plugins/logitech.so
mouseremote         ---   /usr/lib/lirc/plugins/mouseremote.so
mouseremote_ps2     ---   /usr/lib/lirc/plugins/mouseremote.so
mp3anywhere         ---   /usr/lib/lirc/plugins/mp3anywhere.so
mplay               ---   /usr/lib/lirc/plugins/mplay.so
mplay2              ---   /usr/lib/lirc/plugins/mplay.so
pcmak               ---   /usr/lib/lirc/plugins/pcmak.so
pinsys              ---   /usr/lib/lirc/plugins/pinsys.so
pixelview           ---   /usr/lib/lirc/plugins/pixelview.so
silitek             ---   /usr/lib/lirc/plugins/silitek.so
slinke              -a-   /usr/lib/lirc/plugins/slinke.so
srm7500libusb       ---   /usr/lib/lirc/plugins/srm7500libusb.so
tira                --s   /usr/lib/lirc/plugins/tira.so
tira_raw            -a-   /usr/lib/lirc/plugins/tira.so
udp                 -a-   /usr/lib/lirc/plugins/udp.so
uirt2               ---   /usr/lib/lirc/plugins/uirt2.so
uirt2_raw           -as   /usr/lib/lirc/plugins/uirt2_raw.so
usb_uirt_raw        -as   /usr/lib/lirc/plugins/uirt2_raw.so
usbx                ---   /usr/lib/lirc/plugins/usbx.so
zotac               ---   /usr/lib/lirc/plugins/zotac.so
#
#
# Flags:
# E:	Empty: Plugin loaded OK, but is empty (is this a plugin?).
# F:	Fail: Plugin failed to load (unresolved references?).
# a:	Any: Driver can be used with any remote or capture device.
# s:	Send: The driver can send data.
#root@osmc:/home/osmc#

Also the output from:

systemctl status lircd_helper@lirc0 | paste-log

#root@osmc:/home/osmc# systemctl status lircd_helper@lirc0 | paste-log
https://paste.osmc.tv/uwomubebeg
root@osmc:/home/osmc# systemctl status lircd_helper@lirc0
● lircd_helper@lirc0.service - lircd remote support
   Loaded: loaded (/lib/systemd/system/lircd_helper@.service; static; vendor preset: enabled)
   Active: inactive (dead)

Nov 26 12:51:39 osmc systemd[1]: /lib/systemd/system/lircd_helper@.service:6: PIDFile= references path below legacy directory /var/run/, updating /var/run/
Nov 26 12:51:44 osmc systemd[1]: /lib/systemd/system/lircd_helper@.service:6: PIDFile= references path below legacy directory /var/run/, updating /var/run/
root@osmc:/home/osmc#

How about:

ls -al /dev/lirc*

root@osmc:/home/osmc# ls -al /dev/lirc*
ls: Zugriff auf '/dev/lirc*' nicht möglich: Datei oder Verzeichnis nicht gefunden
root@osmc:/home/osmc#

I have a solution.

Thanks, that has narrowed the problem down.

This should now be solved, simply check for updates again.

osmc@osmc:~$ ll /dev/lirc*
crw-rw---- 1 root video 243, 0 Nov 26 13:58 /dev/lirc0

This was fast :slight_smile: Thank you very much!

1 Like

Confirming all fixed here now also - Thanks everyone

Edit: My resident Crash Test Dummy’s (Kids) will hit the system hard this weekend

The problem was indeed solved in a very short time. Chapeau! Remote control works again. Thanks