rpi2 audio passthrough AC3 DTS not working

Hi,

I just updated my rpi2 to latest kodi 15.1 and kernel 4.1.5-1.

It seems that audio passthrough for AC3 and DTS does not work any more.
Also, if I disable AC3 and DTS, kodi does not decode all audio channels. I can hear the music of the movies, but not the voices (like the center channel is not decoded).

Rolling it back everything works as expected.

Any ideas?

Can you upload a full set of debugs on the problematic versions of the software?

Sam

Sure, if you guide me which debug you need… (how to enable in kodi the debug you are looking for and where do I find the debug file to upload)

https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507

Sam

Thanks! But this page shows:

The page you requested doesn’t exist or is private.

ok.

Device: Rapsberry Pi 2
Installation media: NFS root (/boot on sdcard of course)
Connection: Wired
Power Supply: 2.1A
Peripherals: WiFi RT5370 for hostapd (tried without it and without running hostapd - same problem)
Storage: NFS
OSMC version:
PRETTY_NAME=“Open Source Media Center”
NAME=“OSMC”
VERSION=“August 2015”
VERSION_ID=“2015.08-1”
ID=osmc
ID_LIKE=debian

XBMC version:
06:14:32 62.988953 T:1956331520 NOTICE: Starting Kodi (15.1). Platform: Linux ARM (Thumb) 32-bit
06:14:32 62.989014 T:1956331520 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)

Codecs: VC1 and MPEG2

Audio/Video Output: HDMI
Overclocked: No

Log: http://pastebin.com/prVsLZM3

The configuration of your connected audio devices would also be beneficial here I think.

Hi

Can you please enable debugging and post a log when you try to play a file? It will also be good if you can upload some MediaInfo output – https://osmc.tv/wiki/general/how-to-get-mediainfo-output of the file

Sam

What is the Pi connected to? AV receiver or TV? Do you believe it supports AC3 and/or DTS passthrough?

It is connected to an LG Smart TV.
The media player of the TV can play the same file, distributed via DLNA through the same Pi 2, so yes I believe the TV supports that file. Also, the same file plays fine on osmc with the July version.

The debug log includes my entire media library. I prefer not to post it…
Which parts are important for you?

What? I don’t know how this could be the case.

The filenames I mean…

What filenames? The one you attempt to play in order to demonstrate the issue?

No! Every single filename in my media library. It is part of the UPNP debug log.

Specify components and remove UPnP components from logging.

Doesn’t work. I enabled only Audio and Video in components logging and… it still logs my entire media library…

Anyway, it is 2am here. I’ll try to report a log tomorrow.

ok. Here it the debug log:

Any ideas are welcome…

Does disabling “support 8 channel dts-hd” in system/audio settings help?
Does enabling omxplayer in video/acceleration settings help?

Tried all 4 combinations. No luck.

Did you fixed it? I’m facing a similar problem and I don’t know where else to look at…