Rpi2 libcec stopped working after upgrade

hey, I used apt-get update and upgrade, after the update osmc said there was a error I rebooted, no tv controls work. I checked the log and this came up

09:54:17 T:1956814848   ERROR: Unable to load libcec.so.2, reason: libcec.so.2: cannot open shared object file: No such file or directory
09:54:17 T:1956814848   ERROR: Initialise - failed to initialise bus cec

any tips how to fix it ?


osmc@osmc:~$ dpkg -L rbp-libcec-osmc
dpkg-query: package 'rbp-libcec-osmc' is not installed

and when I do cec-client things actually happen …

rbp-libcec-osmc is not the correct package name, for a Pi 2 it is rbp2-libcec-osmc.

If you are still able to navigate some way in Kodi (for example plugging in a keyboard) please use the My OSMC log uploader to upload all logs.

If you can’t navigate in Kodi then use the following via SSH:

paste-log /var/log/apt/term.log
paste-log /var/log/apt/history.log
paste-log /home/osmc/.kodi/temp/kodi.log
sudo journalctl | paste-log
dpkg -l | grep osmc | paste-log

Then post the resulting URL’s here.


amazing little program for logs.

rbp-libcec-osmc was pre RBP1/RBP2 nomenclature, i.e. Alpha 3 or earlier. Your Kodi should also depend on libcec 3 not 2. Please check you’re up to date


I might be up to date but cec is not working for sure, any idea how to debug it or find the cause of it ?

Ok well the cause of your update error is clear:

Log started: 2015-05-12  13:22:59
Selecting previously unselected package xbmc-eventclients-common.
Preparing to unpack .../xbmc-eventclients-common_2%3a13.2+dfsg1-4_all.deb ...
Unpacking xbmc-eventclients-common (2:13.2+dfsg1-4) ...
dpkg: error processing archive /var/cache/apt/archives/xbmc-eventclients-common_2%3a13.2+dfsg1-4_all.deb (--unpack):
 trying to overwrite '/usr/share/pixmaps/xbmc/mouse.png', which is also in package mediacenter-eventclients-common-osmc 1.0.1
Selecting previously unselected package xbmc-eventclients-xbmc-send.
Preparing to unpack .../xbmc-eventclients-xbmc-send_2%3a13.2+dfsg1-4_all.deb ...
Unpacking xbmc-eventclients-xbmc-send (2:13.2+dfsg1-4) ...
dpkg: error processing archive /var/cache/apt/archives/xbmc-eventclients-xbmc-send_2%3a13.2+dfsg1-4_all.deb (--unpack):
 trying to overwrite '/usr/bin/xbmc-send', which is also in package mediacenter-send-osmc 1.0.0-3
Errors were encountered while processing:
Log ended: 2015-05-12  13:23:01

You have manually installed the package xbmc-eventclients-xbmc-send, which conflicts with a package we already provide (and install by default) called mediacenter-eventclients-common-osmc. Please uninstall xbmc-eventclients-xbmc-send and then try to run updates again and they should succeed.

I can also see from the apt history.log that you have been doing a little bit of “fiddling around” :wink: After trying to install xbmc-eventclients-xbmc-send I see you tried to run apt-get -f install, then apt-get upgrade then apt-get install rbp2-device-osmc - I’m interested to know why you tried to reinstall the last one ?

Please note that apt-get upgrade is not sufficient, if you are updating from the command line you should always use apt-get dist-upgrade, as only dist-upgrade will install new packages to satisfy dependencies - upgrade will only upgrade already installed packages. One side effect of using upgrade instead of dist-upgrade is you will not get an updated kernel, but there are others too…

I would suggest the following to get everything back in the correct state again:

sudo apt-get update
sudo apt-get remove xbmc-eventclients-xbmc-send
sudo apt-get -f install rbp2-device-osmc --reinstall
sudo apt-get dist-upgrade

That should cover any problems that happened in the sequence of events that I can see from the logs…

BTW, you seem to have the correct version of libcec installed so after doing the above if CEC still does not work please enable debug mode in Kodi (your logs were not made with debug mode) and post the kodi.log again.

Also, have you tried unplugging your TV from the power to fully shut it down and boot it up ? Occasionally that is necessary if CEC isn’t working (especially after an update) and nothing else can be found wrong.

hey it worked after dist-upgrade, and to answer your questions I thought rpb2 was missing or damaged, I am not so good with linux I am still just learning, thanks for the help :slight_smile: I am really happy with osmc its really nice that you put so much time into building something so awesome, have a nice day

Thanks guys, after apt-get update and apt-get upgrade my remote control also stopped working, and then i only ran sudo apt-get dist-upgrade, and after reboot remote control works again.

Great job…

Do not run apt-get upgrade, only use apt-get dist-upgrade. This is documented in the FAQ.

Using upgrade instead of dist-upgrade will leave your system in a partially upgraded state.