RPI2 v1.2 won't boot OSMC - rainbow

Having some trouble getting OSMC going on an RPi v1.2 Have tried several confirmed working microSD cards in another Pi, and various OSMC images.

Raspbian etc. boot just fine, OSMC gets stuck on rainbow screen, with the green LED flashing 4 times slowly then 4 quick flashes. Any ideas?

Definitely selecting RPi2 image in installer, tried RPi1 just in case but as expected no boot.

Can anyone help please?

If you’re sure it’s a Pi2, then the correct image will have rbp2 in the name. (I did once try a rbp1 image on a Pi3 and got the rainbow screen.)

it might be a power-related issue or a bad SD card. Ensure that the power supply is sufficient and/or try a different SD card.

Definitely Raspberry Pi 2 Model B v1.2

cat /proc/cpuinfo

Gave me a rev number a22042, which led me to Raspberry Pi Documentation - Raspberry Pi hardware

2B (with BCM2837) 1.2 1 GB Embest

Tried several power supplies and microSDs, I’ll hijack the working Pi’s PSU when it’s idle - OSMC being enjoyed by my partner at the mo!

Could it be anything to do with the v1.2 Pi2 using the Pi3’s CPU? Though I’m assuming this isn’t an issue or there’d be more threads here on the problem!


It’s possible that the firmware in the installer images is too old for this to boot properly.

The installer needs a kernel + firmware sync soon to resolve an issue with a small subset of SD cards as well:

So now looks like a good time for us to update and make some testing available.


Interesting page. Not seen it before.

My Pi3 is revision a02082 3B 1.2 1 GB Sony UK

Happy to assist in testing - let me know what’s involved.