RPi3 fails to update from OSMC June 2017 2017.06-1

Hi! I’m using osmc since 2015 and no problems till now… Each time I want to update I get crash when unpacking data (on blue screen). Any clues?

Log: http://paste.osmc.tv/ewuyepikoy

Your SD card might be getting a bit worn out after two years of use. In SSH try this:

sudo rm /var/cache/apt/archives/rbp2-image-4.9.29-9-osmc_9_armhf.deb
sudo apt-get update
sudo apt-get dist-upgrade

I did and still the same problem…

After it I tried:

sudo apt-get clean

and got

W: Not using locking for read only lock file /var/cache/apt/archives/lock

then tried with:

sudo touch /forcefsck && sudo reboot

then again:

sudo apt-get clean

which completed sucesfully.
than again:

sudo rm /var/cache/apt/archives/rbp2-image-4.9.29-9-osmc_9_armhf.deb


No such file or directory which is correct
than again

sudo apt-get update
sudo apt-get dist-upgrade

and now: http://paste.osmc.tv/mafuvifemo.vhdl

SD card has less than one year and it is 10class card…

Any ideas?

Thanks for support!

Read-only file system

Thats not an argument, you SD Card is clearly gone as it became “read-only”
The good thing as it is read-only you still can make a backup e.g. onto a NAS which you than can recover on a new install

Already did it… So need to buy new SD ?

Yes, if you have too much time on hand you can do CPR on the old SD card but I would just get a new one (reminder OSMC gives you life time warranty)