RPi3 Freezing up

Hi there,

My Pi3 has been freezing up frequently since yesterday and only a power reset is starting it up. I am on the latest jan release and nothing changes on the application front. All that was the position of TV (to which the Pi is attached to).

I had to move the TV closer to the phone socket to try and connect it through ethernet, however before I could do that I saw that it has been freezing up very often. It froze on me like 4 times in a span of 2 hours.

I am running pihole, hyperion and rpi-monitor besides OSMC.

Hi,

If you removed the un-recommended addons, with reference to:

link

Do you still get the same issue?

Also its not recommended to run pihole with osmc, as it installs unsupported packages; which means your current configuration is not officially support.

I would recommend reinstalling osmc from scratch and see if the issue persists.

Thanks Tom.

Thanks mate. I have been running this config for close to a year now, so I was wondering if the logs indicate something more specific?

I will however follow your recommendation in the weekend.

Hi,

It seems to be freezing up on loading a stream, which although the addon isn’t listed in the link provided; from some googling it doesn’t like that addon would be supported. I would ask the addon developer for support.

Thanks Tom.

I have the same exact problem on a RPi3. It completely freezes very often since the January upgrade, it never freezed once before that.

No other software is installed, other than vanilla OSMC and python script querying the connected w1-sensor every 5 minutes.

I’m downgrading to the December release right now and will monitor the behavior in the coming days.

Seems like a kernel issue to me (IP connectivity is completely gone as well).

Hi,

Please provide logs:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

@Tom_Doyle not possible if the system is completely frozen.

It’s completely possible after reboot. The logging function will provide Kodi log from the previous boot for just this kind of troubleshooting.

1 Like

You can cause the system journal to be saved to the SD card by creating a directory:

sudo mkdir /var/log/journal

and reboot. Otherwise the system journal is only held in memory (to reduce wear on the SD card).

I recommend that you remove the directory once it’s no longer required.

okay tried something closer to that. Restored OSMC from an August image and was able to update it to the October release of OSMC. However when I attempted to update it again to the Jan 2018 release i am getting this error.

W: No sandbox user ‘_apt’ on the system, can not drop privileges

How should I proceed now?

How did you update to October version?

Hi,

I’ve seen this before in debian based systems, I seem to remember changes made by debian apt/apg-get triggered this. Although its fixable from what I can remember, but its probably easier to back your settings from the October image and install a fresh January image; then restore your settings.

Thanks Tom.

How did you do that? A fresh install with the Dec release or some other way to do from within the jan release?

Yes, a fresh install of the December release image and restoring the files in /home/osmc.

I installed the January release on another SD card and I’m currently monitoring it, as I wait for it to happen again. I had to enable debug mode via advancedsettings.xml to be able to disable showloginfo, as I can’t watch media with the debug info on screen.

I also created /var/log/journal so that everything will be there the next time.

so I did a clean install of Dec rel and loaded it with a few of the addons that can’t be named here. It has been going good so far without any freezes. I will load up all the other add-ons today and use it for the weekend.

will install pi-hole after than and report back if I hit any roadblocks. I might be jumping the gun here, but I feel the Jan release might have been my issue. (a comment made with no real evidence)

Do not install pi-hole! It will mess up the networking as it’s not compatible with connman.

hmm… what sorta symptom I would see in this case? The reason I ask, I have been running osmc & pi-hole for the past 6 months without a hitch until stuff went kaboom last weekend.

I do plan on getting a Pi 0 for pi-hole in the near future, but just curious to know how serious is the osmc - pi-hole conflict.

Pi-hole will cause network problems. And those can show as a variety of symptoms Your freezing could really be just the the network is dying.

I’d suggest that you test all your add-ons, but absolutely do not try Pi-hole again.

ok then… Being a developer myself I know how irritating it is when people ask ‘how did it work so far’, so I’ll just skip that.

while we are on the topic of conflicting apps, I did have rpi-monitor and hyperion on my previous install. Any know issues with these?

(please don’t say hyperion, that would be a deal breaker)

Hyperion should be fine. Not sure about rpi-monitor.

As to why things changed and Pi-hole may be causing your problem… Hard to say exactly. It installs parts of networkmanager which can conflict with connman. It could just be a race condition on what starts first on boot.