RPi3 Samba shares now say 'File exists'

This is the December 2018.12-1 OSMC running on RPi3, and last night I was watching a video stored on a local NAS. Today, I go to restart that video, and I get ‘File exists’. I’ve looked at all the current posts for this message and they all talk about setting up Samba shares and getting this error due to setup. I’ve done nothing (AFAIK) to change the state of affairs, and yet it’s now telling me that I can’t see the content of the shares that I could use last night. I can navigate within the Samba shares, within the directories, but I can’t see the directory contents ("File exists.’).

If anyone can point out what this error is referring to, or what could have happened, I’d be grateful,


Chris M

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

There’s a story by Joe Haldeman, " A !Tangled Web", in which an apology is elaborately phrased, and closes with the words “O, the embarrassment.”.

I have to apologise for an Old Person moment in that I turned off ‘Only allow guest access’ on the FreeNAS Samba share without noticing that it also turned off the Guest access as well. There’s one of my problems, old age being another…

“-I die. Before I die my body turns hair-side-in. People come from everywhere to see the insides of themselves. But the sight makes them lose the will, and all die. O the embarrassment.”

I fixed this problem by not trying to use the samba share by selecting it from the list that it finds.
I added a network location manually and it worked fine.
I even started from a fresh osmc image and I was getting the “file exists” error.
Initially I was cloning my image from a pi3 to a pi2 trying to keep all my settings the same but I was getting the error so I tried a fresh image.