RPiB+ withRC3_Wifi no manual static address connection

From a clean reload to a RaspberryPi official microSD card and with the MD5 sum of the download checked as ok. And with both a mouse and a keyboard connected to the B+. Router set to no DHCP and invisible wifi.

After installation of the SD card and switch on, OSMC went through resizing and loading. Everything reported as correct. Arrowed down to MyOSMC, then to Network . Then get screen as in image below.
The <hidden(psk)> is my router. Mousing over it and clicking results in a letterpad requesting the SSID (accepted) then the password resulting in “no connection”.

There is no where to put in the IP address, gateway,etc as in RaspBMC and XBMC, both of which I have used in the past. Switching to Confluence makes no difference, neither does making wifi visible on the router. The correct SSID comes up instead of <hidden(psk)> but the password is still not recognised as ok.

Just to clarify:

  • did you use one of the installers, or load the image directly?
  • did you select manual network setup? and then specify static IP address?
  • I guess that you mean the router is set not to broadcast the SSID
  • have you tried disabling the adapter, and then re-enabling it?
    -have you tried altering the wifi password to a simple alphanumeric only (not spaces or special characters)?

1 Did not use an installer. After unmount & delete with gparted I used

sudo dcfldd if=OSMC_TGT_rbp1_20150519.img of=/dev/sdc
sudo sync

  1. Yes, selected manual network setup but nothing came up to allow me to specify IP address
  2. Yes, but this is easy to switch off and on on my D-link router and finds the SSID if on.
  3. Have toggled both Enable Adapter and Wait for Network, separately and together.
  4. No but not keen to do so. Will affect iPhone and iPad and another PC if I do! XBMC and RaspBMC and RPi Wheezy all work ok with this password.


You won’t be able to configure manual IP settings until you are actually connected to the Wifi network.

The ability to connect to hidden networks has only just been added in RC3 and has not received a lot of testing yet so a problem with this is the most likely reason you can’t connect. Can you temporarily un-hide your network and see if you can connect to it when not hidden to confirm it is not some other issue ? And if you are able to connect, see if you can then configure static IP settings.

CC @gezb

Can you upload logs using the log uploader (with debug logging enabled) after you have attempted to connection to your router please I’ll have a look and see if I can see why it is failing (Wiki - OSMC)

Have you tried connecting using connmanctl outside of kodi ?

1 Like

Did a clean restart again with the wifi visible and SSID being detected. No change-could not configure static wifi. Then connected to eth0 with cable, got eth0 working and retried wifi. Still nothing. (Cable is a nuisance to use all the time).

After cable connected as D post, did a log upload at approx 14:04 GMT. URL begins with ‘aloy’.

Have not tried using connmanctl outside of kodi .

You must provide the entire log URL please.


I think we know what’s happening here we have a fix which is currently being tested

An update should be released soon

…fortunately noted… aloyugofel … hope that is right! Thanks for your support work. Much appreciated.


I could not find a log for “aloyugofel”, but if the issue is what I suspect it is we have just pushed an update to the osmc-mediacenter-addon package that should fix this issue

Could you run an update and try connecting again?

Thanks-I have run the update and am now able to connect with wifi.

It did however take a great deal of persistence and patience on my part to get there! Firstlly I had to request the update 3 times before it completed properly. Then the interface for Wifi manual address was very flaky to use. It took the IP static address ok but the network, gateway and DNS had to be done repeatedly to get them in the right place. Using the keyboard was definitely better than the mouse.

I hope you will eventually put the setup back into the Confluence skin as this works much better where it can be used.

I configured all of my pis with a static ip address with a oneliner for cinnmanctl via ssh. That’s more conbenient that fiddling with the gui imho.