Running squeezelite vero 4k+ kodi 19

Hi, I followed the instructions here in order to install squeezelite onto my vero 4k+. After the update to Kodi 19, my logitech media server doesn’t see my vero 4k+ as an endpoint anymore. I’ve reformatted my vero 4k+, installed the latest version, and followed that same guide again. It showed up briefly but is no longer showing up again.

I’ve looked for an up an updated guide or steps but I haven’t anything newer than that 2017 post.

I use PCM out
I don’t install any additional add ons
It’s pretty much just stock vero 4k+

Thank you,

I’m not sure how the Kodi update could impact this but don’t know enough about SqueezeLite to advise.

Not sure if this related but the actual logitech media server will not run anymore on kernel 4.9 …i am going to have to roll back one of my Vero’s to the old image so i can get it back working …

thanks for the response. I’m not running logitech media server on my vero 4k+. It’s running on a seperate PC. If it matters, I have two vero 4k+ end points. I gave them both unique names in the setup. I’m not sure if they could be interfering with one another or not?

What error do you get?

Hi Sam

It is not a very descript error , when it loads we are getting an illegal instruction error .
We have been in touch with developer and he believes it should work and the version of pearl 5.28 buster ships with is compatible. I have done many things to debug , even recompiled on the Vero and tried a docker version …one of those ones where i think i have to admit defeat and go backwards if i need to use the product.

If you post these messages I can investigate.
We released Buster on 3.14 – so it won’t be a Buster issue but rather a change with the new 4.9 series kernel.

Sam

Ok Thanks Sam

Here is the error log

As i said it is not very descript

Here is a link to the thread and the error is below …

https://forums.slimdevices.com/showthread.php?115062-Installing-on-OSMC-on-a-Vero4k/page2&highlight=vero4k

Your locale was detected as C, you may have problems with non-Latin filenames. Consider changing your LANG variable to the correct locale, i.e. en_US.utf8
dirsFor: Didn’t find a match request: [scprefs]
[21-08-31 21:19:43.6141] main::init (390) Starting Logitech Media Server (v8.2.1, 1628483320, Mon Aug 9 06:45:15 CEST 2021) perl 5.028001 - arm-linux-gnueabihf-thread-multi-64int
dirsFor: Didn’t find a match request: [videos]
dirsFor: Didn’t find a match request: [pictures]
[21-08-31 21:19:43.6449] main::init (420) OS Specific init…
[21-08-31 21:19:43.6461] main::init (467) Server settings effective user and group if requested…
[21-08-31 21:19:43.6471] main::changeEffectiveUserAndGroup (1018) Warning: Logitech Media Server must not be run as root! Trying user squeezeboxserver instead.
[21-08-31 21:19:43.6493] main::changeEffectiveUserAndGroup (1089) Running as uid: 110 / gid: 65534 65534
[21-08-31 21:19:43.6591] main::init (484) Server binary search path init…
[21-08-31 21:19:43.6606] main::init (488) Server PluginManager init…
[21-08-31 21:19:43.8957] main::init (491) Server strings init…
[21-08-31 21:19:43.8995] Slim::Utils::Strings::loadStrings (125) Retrieving string data from string cache: /var/lib/squeezeboxserver/cache/stringcache.armv7l-linux.bin
Loaded module: [DBD::SQLite] ok!
[21-08-31 21:19:43.9112] main::init (503) Server SQL init (Slim::Utils::SQLiteHelper)…
[21-08-31 21:19:43.9125] main::init (507) Async DNS init…
[21-08-31 21:19:43.9136] main::init (510) Async HTTP init…
[21-08-31 21:19:43.9148] main::init (515) SqueezeNetwork Init…
[21-08-31 21:19:43.9345] main::init (520) Download repositories init…
[21-08-31 21:19:44.0841] main::init (523) Firmware init…
[21-08-31 21:19:44.0856] main::init (526) Server Info init…
[21-08-31 21:19:44.3352] main::init (529) Server IR init…
[21-08-31 21:19:44.3582] main::init (532) Server Request init…
[21-08-31 21:19:44.3723] main::init (535) Server Queries init…
[21-08-31 21:19:44.3738] main::init (538) Server Buttons init…
[21-08-31 21:19:44.3795] main::init (546) UDP init…
[21-08-31 21:19:44.3823] main::init (549) Slimproto Init…
[21-08-31 21:19:44.3840] main::init (552) Cache init…
Illegal instruction

Thanks. Read your thread on that forum.

Can you post output of dmesg | paste-log?

Please also update to latest kernel:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

We might need to use GDB to determine what the illegal instruction is

Cheers

Sam

1 Like

Hey Sam,

The development Kernel has fixed the issue . Thanks so much mate , more importantly happy wife now.!!

Cheers
Adam

Glad to hear this.

Please update the forum thread on SlimDevices for the benefit of others who may stumble across this.

Fix will be in the next release

Sam

Will the kodi log catch terminal commands that I execute through putty? I started the vero4k and then I putty into it and reran the commands to start squeezelite. It’s still not working. I have a log but I don’t know what I’m looking for in it.

Thank you,

history | paste-log might.

that only showed the log of my commands. it didn’t show anything about what vero was doing.

!!! Although ended up getting the systems working again. I had to purge squeezelite and reinstall.

sudo apt purge squeezelite
reboot
sudo apt-get install squeezelite
sudo systemctl start squeezeliteplayer.service

I guess this could have been a straight forward thing to try originally. I don’t know why this worked. I appreciate everyone’s feedback. Love the systems and product.

Thanks!