Sad face loop after OSMC's August update


I updated my pretty new Vero 4K today with the latest update by following a reminder when I was going to use it. Sadly, after the update, the vero 4k is stuck in a reboot loop. It shows the menu for 2 seconds and then switches to the sad smiley and is stuck there for about 10 seconds, and this loop continues on and on…

I grabbed the log and pasted it here: but i can’t see any problems occur in that one…

What is this problem?

Can you try

sudo apt-get update sudo apt-get dist-upgrade sudo reboot

from your SSH terminal?

For some reason, Kodi is failing to start. Unfortunately, I can see no indication in the log as to what the problem is.

If ActionA’s suggestion doesn’t help, please try this:

mv .kodi kodi.bak
sudo reboot
1 Like

Did you install some new add-ons recently?
I can’t think of anything that would cause this and the forum remains relatively quiet after the update.

I’d advise following @ActionA and @dillthedog’s advice.


I have the same problem, it started today after the update. I tried to run the commands from @ActionA and @dillthedog, but they didn’t resolve problem.
Also I checked my home folder and the .flexget folder that I had there now is gone, it may have something to do with the problem?


Some logs will help identify the problem.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I’ve been trying to run grab-logs -A but I get this error -bash: grab-logs: command not found.


/usr/bin/grab-logs -A

Don’t work :frowning:
bash: /usr/bin/grab-logs: No such file or directory

Not good. It looks like some kind of filesystem corruption.


/usr/share/kodi/addons/script.module.osmcsetting.logging/resources/lib/ -A

You might want to copy/paste this one!

I can’t run this either, there’s nothing inside /usr/share/kodi/addons/script.module.osmcsetting.logging/

And now things just got a lot worse, I’ve checked my two hard disk (3TB each one) and they are completly blank… I just lost my movies, tv shows, music, everything…

It looks like you have filesystem corruption causing many problems. Did you pull the power during the upgrade?

Your files are probably still there, the drives just are not being mounted. Try connecting them to a different system to verify.

At this point, I’d think that a full re-install is needed.

@dfabarbosa I’m sorry to hear you’re having a problem with your Vero 4K.

I’d recommend a reinstallation.
If you still experience problems, we’ll send you a priority replacement promptly. Filesystem corruption shouldn’t be happening on the Vero 4K unless you’ve experienced power loss, because we use very robust eMMC storage which is certifiable for industrial applications.

Please let me know your order # so we can proceed further.


There was no problem during the upgrade… I even used it to see some tv shows after the upgrade…

Well I just tried the drives in windows, linux and mac, and there’s nothing in them… At this moment I don’t know what to do to recover the content…

Can you tell me how to re-install?

As Sam says, tt looks very much like a serious filesystem corruption that will require a reinstall of OSMC.

You might want to attach a USB flash drive and copy your .kodi (or kodi.bak) directory to it:

cp -r .kodi /media/<flashdrive>

though there’s a reasonable chance it too will have been affected.

See Reinstalling OSMC - Vero 4K - OSMC

Check the drive’s health with a tool. If it’s in a caddy, you may find smartctl info isn’t relayed properly


Thanks for the link, I will try reinstalling and let you know if it works.

One question that pop up my mind. Do you have the same problem on the same device? Means are you using a Vero4k?

Yes I am using vero 4k.

1 Like

I had this problem, after every update, with kodi skin. If u use osmc’ skin any sadface