Sad face loop - Samba share

Hello everybody!

I have osmc 2016.16-2 installed on my raspberry pi 1st gen. For the past 3 years it worked seamlessly as a media center,running a samba share to be accessed in my LAN and Transmission for seeding purposes.

For the past 15 days it is stuck in a “sad face loop” .After multiple times formatting my sd card and reinstalling osmc(plus samba+transmission) the result was always the same:after rebooting the device it always stays in the same sad face loop. If not rebooting,it was working perfectly.

Funny thing is,I tried rebooting after clean install (without anything installed)and it reboots just fine. After installing samba though,which works just fine and i can access shared folders from inside my LAN,if i reboot i get stuck again in the loop.

The steps i take to config samba are:
1)create a direcory, unmount my external hd and mount it in said directory
2)edit /etc/fstab to automount it
3)install samba and edit /etc/samba/smb.conf
4)add user to samba service and restart samba service

As i said earlier,samba seems to be working even when on the sad face loop. I ve also tested my sd card to check if it’s corrupted, but seems to be running fine. Also from similar results on forum i must say that there’s no overclocking and i m using default osmc skin.

Output of grab-logs -A is .

Any help would be greatly appreciated .Thank you for your time and sorry for my English :slight_smile:

Start-Date: 2016-08-06  13:08:00
Commandline: apt-get install samba samba-common-bin

Any reason why you aren’t using the samba server provided by OSMC in MyOSMC app store?

/dev/sda1 /media/USBHDD1 auto defaults,noatime 0 0

Also, you really shouldn’t use /media for fstab mounts. In OSMC /media is handled by the automounter and issues can arise when mounting in it from fstab. The readme in /media should spell this out pretty clearly. Try using /mnt instead. Best practice is also to use the x-systemd.automount flag in your fstab options under systemd.

1 Like

Firstly,i would like to thank you for your timely response.

Truth is i would like more control on who can access the samba share eg whitelist only my PC etc. That said i have tested the app and it works perfectly.

Really sorry for overlooking this,hadn’t read the file at all…

That will definitely do the trick!Thank you very much again,for your kind response dear sir/madam! :slight_smile: