Sad face loop when enable openvpn

Hi, I’ve just installed openvpn in Vero 4k+ and when I start the service Kodi just enter in a sad face loop.

If I stop the service (systemctl stop openvpn*) all works fine as allways.

Here are the logs:

Any help would be appreciated, I have tried a lot of configurations and anything works.


Hi. openvpn software is already installed on OSMC, so could you explain in more detail what you mean?

And yes, Kodi is crashing. Did this first occur after you “installed” openvpn?

Are you trying to use openvpn as a client or a server, since the log shows that both seem to be starting?

I’m trying to configure an openvpn server. When I say “i’ve installed it” I mean that i have configured and enabled a new server in systemd.

I don’t know why the client is trying to start, I haven’t configured it. I will try to find where is the client trying to start.


P.S.: And yes! Kodi was working before enable the server in systemd. If I stop it Kodi works again.

If you set verb 3 in the config file we might see what’s happening.

SOLVED! I’ve a client and two more servers trying to start at the same time (I don’t know why, maybe I have configured it many times).

After disabling all the other services still fails.

Finally setting openvpn service to wait for network and start after all the other services works fine again and i can connect to Kodi from WAN :heart_eyes:.


1 Like