Sad face

Turned on my projector a few days ago and my pi3 running OSMC was showing a sad face. Tried rebooting, same issue. I have installed deluge daemon, spotify-connect and syncthing. I’ve stopped all of these individually, no effect. I can ssh in fine, syncthing, deluge and spotify all work fine, just can’t get the osmc gui working.

I’ve been reading around the forum and have tried all of the following:

I’ve looked at my guisettings.xml file, this is blank. I guess this might be the problem? Can’t find the advancedsettings.xml file.

I’ve moved .kodi to kodi.bak and rebooted, no change. FYI, it does not create a new .kodi folder. I’ve also tried disabling all add-ons individually.

I’ve turned off overclocking by editing /boot/config.txt

I can’t get grab-logs -A to do anything, it gives the error: Unable to write temporary log to /var/tmp/uploadlog.txt Failed

Any ideas would be much appreciated.

Hi. Welcome to the forum.

Being unable to write to /var/tmp might be a space problem. Please run

df -h

2 Likes

Ah… That was it! After all that messing around! I really should have worked that out by myself… I’d synced some large files recently.

Thanks very much! Working fine now.

Great to hear that all’s now well. Thanks for letting us know.