Samba Installation Error

Can someone please help me out, I’ve spent days trying to figure this out

Here is my what i keep getting:
[…] Starting smbd (via systemctl): smbd.serviceJob for smbd.service failed. See ‘systemctl status smbd.service’ and ‘journalctl -xn’ for details.
osmc@osmc:~$ sudo /etc/init.d/nmbd start
[…] Starting nmbd (via systemctl): nmbd.serviceJob for nmbd.service failed. See ‘systemctl status nmbd.service’ and ‘journalctl -xn’ for details.


Who not much to go on, need some more info.

How did you install samba? Via App store?
Also provide the URL that grab-logs -A gives you

BTW, you should use sudo systemctl start samba to start the service

I did
sudo apt-get install smb-app-osmc

I tried systemctl and /etc/init.d/ and still doesn’t work

Ok, it looks like you tried to purge a manual samba installation before you installed the app-store one.
Something seemed to have gone wrong there.

Suggest you purge all versions (app-store one and manual one), delete /etc/samba and then try one clean install of the app-store version.