Samsung CEC connection disconnects over time Pi2

Hi all,

I am experiencing a weird problem that just emerged about a week ago. I have a Pi2 connected to a Samsung Plasma via HDMI. I control my Pi using the remote, I have been doing this for at least a year, maybe 2, with no issues.

Recently I have noticed that after a while, if I come back to my Pi and attempt to use the remote, it is not recognized. If I go to my Tvs connected devices I see 2 devices “raspberry” and “kodi”. Kodi is the correct option, but for whatever reason, I cannot switch to Kodi. Turning off CEC on the TV does nothing, turning on and off the TV does nothing, refreshing the connection list does nothing, unplugging the HDMI and plugging it in again does nothing. The only resolution is to hard reset my Pi by pulling the plug. This resolves the issue.

This leads me to believe that the service running on the Pi is timing out, crashing or disabling itself - but I do not know how to troubleshoot any further.

Any suggestions?

Please follow the instructiins in this wiki post to submit a full debug log showing the issue happening.


Im right now, also not sure. But my Rpi behaviour is the same or similar. I was not sure if this was because i added the hdmi audio extractor between tv and rpi but i also ran an osmc update, so I must try again if the issue was coupled with osmc update or the hdmi audio extractor.

Generally what help my now is to push the tools button on remote, then click on anynet cec and confirm again the kodi, which will again turn on the cec to rpi.

Let me know, if this helped you.

Thanks! I have tried this multiple times and it will never switch back to the kodi option. It seems to show Kodi and then a phantom option either “raspberry” or “recorder” - the only thing connected to my TV is the OSMC Pi This is my kodi.log file. I believe it shows the error, but I have no idea.

I updated OSMC last night to see if that would make a difference, but this morning when I went to use Kodi the remote was unresponsive again and the anyconnect listed “recorder” and “kodi” as the options, with Kodi unable to be selected.

Sorry - this issue seems to happen randomly over time, so it’s difficult to replicate accidentally. last night I rebooted, updated, and uninstalled a bunch of add ons. Turned the TV off, left Pi on, went to bed. I turned on the TV today and the pi was not recognized. I pulled the plug, watched a tv show then enabled debug logging. I have tried turning my TV on and off again, but this will not replicate the issue. I switched inputs on my TV as this seems to cause the issue so hopefully it’s captured in the logs.

Have you tried this?

WINSCP wont let me write to /boot, any suggestions?

Also, I think the issue stems from the HDMI connection to the Pi being detected twice, once as “raspberry” once as “Kodi” up until last week it was only ever Kodi, and everything worked fine. In that time nothing has changed in terms of software or hardware - so I’m not sure?

Resolved the issue with winscp - tried what you suggested, and rebooted - still two CEC/HDMI connections showing up for the Pi, and connection still dropping when I try to switch between them. Thanks!

Please re-read the article on how to submit logs and submit a full set of debug logs. The extract you have posted shows nothing relevant as after you have pulled the plug the kodi.log file is emptied, we need both kodi.log and kodi.log.old and your config files. Using grab-logs -A as detailed in the article will provide all those logs. It is also imperative that your have debug logging enabled so we can see exactly what is happening.

Better than pulling the plug would be to emable debug logging, wait until the issue happens and then connect to the Pi by SSH using Putty and upload the logs by running the grab-logs -A command before rebooting.

Unplugging will eventually damage your SD card, better to log in by SSH and run sudo reboot. You might not even need to do that; sudo systemctl restart mediacenter may resolve the issue without a restart.