Save my old pi1

I bought a pi2 recently and i’ve been using OSMC on it full on a SD card, without any USB HD drives.
I still want to use my old pi1 ModelB though which was a SD+USB setup. The system was booting from the SD card but the whole OS was in the USB stick.
Now that thing was running Raspbmc and thats fine by me. I have all my addons and bookmarks on it and i dont mind keeping it like that. The problem is that i lost the boot SD card. The usb stick is fine but i got nothing to boot it up with.
Until a new card arrives i have a spare 32MB SD card. I’ve read on the internet that the pi can boot up with a 32mb card but no matter what i tried i cant get it to work. I tried making a Fat partition and just copy paste my USB’s boot dir contents in it but i am not sure what to do in my config.txt

Not to mention that i get no signal on my monitor while the pi is booting up…just a flashing green light on the pi after 30 seconds.

Can someone help me revive my old pi ? There must be an easy way to ‘redirect’ the boot to the USB. Everything was like working fine before, even with Raspbmc.

I am using the whole usb stick as ext4. I got no access to it from windows.

-Thanks

No, the pi needs an SD card to boot up, there is no way around it.

For this you will need another USB stick

Connect that usb stick to the pi. disconnect your old usb stick. boot up with your SD card. and then disconnect your new usb stick and connect your old usb stick. Though you may need to remember which version you installed.

Hi,
I have a spare 32 MB SD card…the usb with the Raspbmc is working fine as long as the SD card ‘redirects’ to the USB instead of trying to find the system in the SD card.
All i need is a tiny boot image that in the commandline.txt redirectes the /boot process to the USB.

+1 for what jloh suggests. Install Raspbmc on another USB stick then reboot having replaced it with your old USB stick. The boot partition installed to the SD should be the same no?

well…the SD card isnt compatible with the pi…thats my final conclusion :confused:
I guess i have to wait for the new card to arrive.
i backuped up my pi2 sd, and with an SD adapter i put the minimum boot image i found here: » Boot Raspberry Pi from a 16MB SD card
and that worked fine…I did the same with the 32mb card and i got nadda on the monitor…so it must be the card.

Thanks for the help guys

Try reloading the SD card. The SD cards sometimes get corrupted. but unless you want to overwrite the data on your usb stick, I still suggest you swap out the usb stick and then swap it back in.