Screen going black, sound disappearing, on 4k material

Hi, I’ve just got my 1st 4K TV but am finding a regular problem, in that when playing 4K material from my NAS after a couple of seconds sound and vision disappear for a couple of seconds. I’ve included the mediainfo of the file which most consistently reproduces this, and full logs for the event. I did find several other posts with this problem but I’ve either tried those solutions (Gui to 1080p, Adjust Display Refresh Rate on Start/Stop etc) or lacked the knowledge for the other suggestions.
logs -
mediainfo -
Any help appreciated as this buying this TV was a hard sell with the wife and these black holes aren’t making life any easier!

Does the picture eventually come back?
Does it only go black at the start?


Hi Sam. The picture and sound always return after about 2 seconds. On this (and the 2 other) short LG demo clips it only occurs the once, at the start. On full films (rips) it originally was only at the start but has now progressed to around every 15 seconds. It’s sometimes preceeded by a few instances of red line tearing. The Vero is straight into the TV (no AV amp) and I’ve swapped cables and inputs.

Should have added - it never occurs on the GUI or non 4K material.

Can you try changing the HDMI cable and enabling 4:2:2 output under Display settings?

A couple of seconds of black screen at the start of playback is expected if adjust refresh rate is enabled. This is because your TV needs to ‘lock on’ to the new signal with the new frame rate that we send. But this should then not occur until the playback stops and goes back to the GUI refresh rate when you either press Stop or let the programme run its course

I’m assuming that’s ‘Force 422 Colour subsampling’? That was already enabled, so before hunting for some cables I’ve switched it off, and on a quick test of material that was unhappy earlier, no cuts to black. Re-enable it - fault returns! I’ll do a longer test but this looks promising.

What’s the make and model of your TV? Foolishly I read LG demo clip as LG TV (skim reading).

Is there an AVR between?


Samsung QE55Q90R. No AVR - it’s straight into the ‘One connect box’ which this model has.

Just as a quick check, but did you set HDMI UHD Color to ON, at the HDMI port the vero is connected to?

Hi MTV, not that I know of! Not had proper time to look into settings yet, I’ve just let it do it’s own thing. Do you have this set? Do you recall how to get to that setting?

I have the Q9FN (2018).

Settings - General - External Device Manager - Input Signal Plus

page 109 of emanual
page 165 for clarification

Thanks for that. I do recall now seeing a fleeting message when first connecting the Vero that the set was automatically adjusting something - looks like it was this. On this set there’s no further options available apart from toggling the function on/off - I’m guessing that’s the same on yours? I’ve switched colour sub sampling back on and tried with Input Signal Plus both on and off, and dammit - I can’t get the initial fault to re-appear, lets hope that lasts.

I have had the same pop-up on my Samsung qled the first time i connected the 4k+ .
The screen glitched after the message a few times and after that perfect screen quality.
I did swapped the included HDMI cable with a 2b cable ,because the tv dindt like the cable that was included with the vero .
Now enyoing mi perfect 4k player🎉

I think a cable update for me is probably overdue. Although choosing those seems another minefield. I’ve always gone with ‘Amazon basics’ before but 4K seems a bit more choosy.

I used belkin cable between vero -> avr and avr-> tv

Belkin AV10175br2m-blk, works perfect for me

Thanks - I’ll go find.