(Seemingly) Random freezes

Hi there

Been having a few freeze ups in the last few weeks. Seemingly random, just had one watching a TV episode. Sometimes can go a few days without issues, usually happen watching something but a couple of times have found the Vero 4k unresponsive when it’s been left, say overnight. After all these freezes I cannot SSH in and have to power off the Vero 4K.

Here’s the logs taken just after restarting after the last freeze: https://paste.osmc.tv/ocugatadur

Only running on OSMC skin at moment - trying to eliminate if it was a heavy skin issue as had been using Titan previously.

Also using an old RC6 remote at the moment as the Vero remote seemed to have stopped working yesterday, but that’s another issue and I’ll open a separate thread if I can’t resolve that.

The only maybe slightly unusual part of my setup is that I use 2 separate powered external HDDs directly attached to the Vero which I use samba to transfer files to from a Win 10 laptop (I’ve tried 2 different hubs inc. the OSMC store one and one into each USB slot on the box just to try to eliminate if that was an issue.

The Vero 4K runs via a certified HDMI lead (I’ve tried 2 others with no success) to my AVR, a Marantz SR7011 then onto a Samsung 55KS7000 TV connected to that with ARC enabled. I’ve tried various combinations of CEC on/off etc to try to eliminate that but again, no difference.

Think that’s about it.

Run out of ideas now.

Can you offer any assistance?

When the device becomes unresponsive is it hot?

Mobile so haven’t checked logs yet, but are you running a lot of addons or background services?

If so — you could try disabling them and reenabling one at a time.

Can you try removing a disk one at a time to see if it improves things?


Hi Sam

No, not hot at all. Luke warm at most.

Reinstalled recently (to eliminate that!) and only addons are those the OSMC skin required I think.

I’ll try the disk suggestion next. It may take a while before I have anything to report though, as I said, it can be hours/days between freezes.

Btw, I had a spare compatible power supply which I have tried to hopefully eliminate the power supply possibility but the freezes still occur.

Also, after the last reboot I watched the episode that froze previously right through without issue, so I guess that eliminates a corrupt file.

We had a nasty issue where a user with a disk on its way out had freezes before. This was caused by kernel panics from trying to access the filesystem.

Unfortunately you do have a few variables, but we should be able to help you narrow things down pretty quickly and work out the root cause.


There is an error just after the tv show started playing:

17:48:46.756 T:3420713728 ERROR: Unable to load libamplayer.so, reason: libamplayer.so: cannot open shared object file: No such file or directory
17:48:46.756 T:3420713728 WARNING: CAMLCodec::CAMLCodec libamplayer.so not found, trying libamcodec.so instead

I dont think this error would cause a freeze. It’s related to playback of .mkv files.

If you can play the same episode again without freezing, then it must be an intermittent issue.
Like overheating, or a hardware (maybe HDD or PSU) issue. I think it’s a process of elimination.

Maybe try for a day or two with just one of your HDDs connected, and see if the freezes are gone/the same/more often.

That’s not really an error.
Kodi looks for libamplayer.so first instead of libamcodec.so first.

So it generates a small warning.

Hi again

Just had another freeze.

Happened while transferring some files from laptop to disk attached to Vero 4k.

Wasn’t using Vero for anything other than that at the time.

Had previously watched a tv episode to that without issue that I see is mentioned in the logs.

Have been running just the one external drive as suggested, nothing else USB plugged in.

Logs here: https://paste.osmc.tv/evorekoleq

I think the disk may be the culprit then.
Are you able to run without any disks for a while?


Worth trying out the other disk? Haven’t really got any other way to get media to the Vero 4k otherwise. Or do you mean just let it run to see if it freezes on its own?

This would be the best way.

You could try the other disk for now, but the only real way to rule things out will be to remove both disks.


Just had another freeze.

Had been missing my media so had dug out my old Acer revo and set it up to share to the Vero 4k. Froze whilst watching a movie from the ‘other disk’, i.e. not the one with potential problems yesterday. Only things attached to Vero are remote dongle, hdmi lead, ethernet cable and power lead.

When it works it’s fantastic. Superb picture. Great sound. But the freeze ups are getting a bit annoying.

Logs: http://paste.osmc.io/ekulovoweh.coffee

Thanks for any assistance.

I can imagine.

A couple of things:

22:04:24.921 T:3414160128 ERROR: Open - Error, could not open file smb://DESKTOP/films/file2/file2.mkv

Are you having problems with playback here?

You don’t have Kodi debug logs enabled yet, but if you only have the OSMC remote attached, and the install is fresh and still freezes, then something isn’t right.

If the problem is exacerbated by having disks attached, it may be power related. Can you let me know your order # so I could send you a new power supply? It looks like you’re in the UK, so you would receive this on Monday morning.


Hi Sam,

Thanks for the reply.

No, I thought that entry was a bit strange (not that I know what most of it means) - I hadn’t played or even looked at that file at all.

Just had another freeze, this time just as I was about to select ‘yes’ to the ‘would you really like to remove’…etc delete option.

Do want those logs too?

I have tried the original and a spare power supply, but happy to give another a go.

Is the order number OK to put on here?

Just had a quick search and seen you’ve said to post order number here - it’s: Order #11388

Second logs: https://paste.osmc.tv/bisuxijitu.vhdl

Safe to put the number there, as no one can gain any information from it apart from us.

I’ll send you a new PSU, and would appreciate it if you could start fresh from Download - OSMC when you receive it.

Build up slowly.If you get a freeze, work out what you changed recently.
Your symptoms are extremely rare; which is why there’s no defacto way of resolving them, but I appreciate your patience and I am sure we can work it out shortly.

We test every single device, but we can’t test power supplies as strenuously. If things are still problematic, we’ll swap the device over for a new one; but I don’t think things will get that far.



Just to confirm that a new PSU has shipped today.

Thanks for the info Sam.

Btw, swapped back to the original power supply this morning, had been running ok but had a freeze during an episode I was watching a while ago. Power cycled, checked file played past freeze point, stopped play and got logs: https://paste.osmc.tv/ayaqusoqak.coffee

I can see a few errors (below).
The Samba symlink one with the garbage characters (in bold) might be an issue.

The tricky thing here is that the issue isn’t reproduce-able. If the freeze is happening with both original PSU and replacement PSU, then we can eliminate power/overheating.

Maybe if you try eliminating Samba and the USB HDDs.

Try copy a few video files to a local folder on the Vero 4K, and see if it’s more stable. If you don’t get any freezes over a day or two with only local video files, then we’ll have a better idea where the problem is.

Hope this helps.

Best regards,

12:26:15.153 T:3600806656 ERROR: DoWork - Direct texture file loading failed for resource://resource.images.weathericons.default/.png

12:26:13.022 T:3975463680 NOTICE: Register - new cec device registered on cec->AOCEC: CEC Adapter (0000:0000)
12:26:13.401 T:4076724816 WARNING: JSONRPC: Could not parse type “Setting.Details.SettingList”

12:26:11.322 T:4076724816 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
12:26:11.441 T:4076724816 NOTICE: Running database version Addons27

12:26:11.210 T:4076724816 ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

Samba is not being run as an AD Domain Controller, masking samba-ad-dc-service.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc-service.
Created symlink /etc/systemd/system/multi-user.target.wants/nmbd.service → /lib/systemd/system/nmbd.service.
Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
Created symlink /etc/systemd/system/multi-user.target.wants/smbd.service → /lib/systemd/system/smbd.service.

Feb 02 11:30:59 osmc systemd[1]: Reached target Network.
Feb 02 11:30:59 osmc sh[367]: lircd: WARNING: garbage after ‘name’ token in line 304 ignored
Feb 02 11:30:59 osmc sh[367]: lircd: WARNING: invalid code found for Xbox: KEY_PAUSE
Feb 02 11:30:59 osmc connmand[364]: iptables support missing error 2 (No such file or directory)
Feb 02 11:30:59 osmc connmand[364]: Failed to flush table ‘mangle’: Invalid argument

Feb 02 11:30:58 osmc kernel: hub 2-0:1.0: USB hub found
Feb 02 11:30:58 osmc kernel: hub 2-0:1.0: config failed, hub doesn’t have any ports! (err -19)

So, received new power adapter last Monday, thanks Sam.

Plugged it in, got a freeze watching a downloaded TV episode. Rebooted OK but watched episode on different device.

Left Vero 4k overnight, it had frozen again on the OSMC skin. Decided to reinstall OSMC as I think you suggested and thinking it should remove the errors that anbodearg pointed out above (thanks), did so from USB stick with December image (with the installer) then updated to the January release. Everything OK for a few days/evenings using it for downloaded TV show/film viewing and some music playing.
Played some music last night using the Vero 4k. Switched to watching some ‘normal’ TV, not using the Vero 4k. Switched back over to Vero and it had frozen again. Left overnight just in case it magically un-froze overnight, no such luck. Rebooted it. Took some logs using grab-logs -A:


Not installed any addons except for skin shortcuts and artist slideshow that are listed as recommended and supported addons in the OSMC skin settings pages.

Only official remote dongle, ethernet lead, HDMI cable and power connected to Vero 4k.
Vero is cool to touch.

Whilst writing this it has frozen again on the OSMC skin home page.

What now?