Selenium broken after update

I’ve installed Selenium on a RPi2 to automate web page interactions. This worked perfectly until I updated OSMC this morning. Now I get the error message

Traceback (most recent call last): File "/media/", line 23, in <module> wd = WebDriver(fp) File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/", line 77, in __init__ self.binary, timeout), File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/", line 49, in __init__ self.binary.launch_browser(self.profile) File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/", line 68, in launch_browser self._wait_until_connectable() File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/", line 103, in _wait_until_connectable raise WebDriverException("Can't load the profile. Profile " selenium.common.exceptions.WebDriverException: Message: Can't load the profile. Profile Dir: %s If you specified a log_file in the FirefoxBinary constructor, check it for details.

I’ve no idea how to solve this. Does anyone else have an idea?

Turn to the addon developer instead of OSMC forums

There is no indication that Selenium has anything to do with banned addons or pirating content. If you are too lazy to conduct a simple google search, just ignore the thread so you don’t look foolish.

in anycase the first sentence holds true and i dont mind looking like a fool at times rather that then something else :wink:

Solved this issue by updating Selenium with:

sudo pip install selenium --upgrade

Not sure what was broken, but everything is working now.