Setting content for library - nothing happens

Hi there,

I was just setting up my new vero 4k+. I’ve connected a 8TB Seagate harddrive (NTFS) to it. Browsing files works perfectly, also playing them (.mkv,.avi etc) is no problem.

No I wanted to build a movie library by setting some of the movie folders from the harddrive as content as it is described by kodi. After setting up the source and clicking “yes” for the “update entries blabla”-window showing up, nothing happens. No percentage processing in the top corner, nothing.

And of course, none of my movies is showing up in the movie library.

I’ve tried everything by changing all options while setting-up content. Stil, nothing happens.

My movie-files are sorted in to folders by category. Some of the movies are again placed in folders with the name of the movie.

Does anybody know what the problem is?

Thanks in advance!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here are my loggs:

http://paste.osmc.tv/pesinomiho

Thanks

Setting a source for the appropriate type of content is the first step. Ending this dialogue won’t start the scraper for this section, though. You can either have it update on every start or start it manually:

https://kodi.wiki/view/Updating_or_removing_videos#Update_Library-_Automatic

Before you do this, please make sure movies reside in a folder only for movies (best case: appropriately named subfolders for every movie). Same thing for TV shows.

https://kodi.wiki/view/Naming_video_files/Movies

https://kodi.wiki/view/Naming_video_files/TV_shows

I already did all these steps. None of them works.

As I said, no source is added, my libraries are empty. Nothing can be updated, not manually nor automatically.

I’m setting the content by choosing the movie folder of my harddrive. But nothing happens afterwards. Updating the non existing library doesn’t solve the problem. I tried it several times.

Since I bought my vero 4k+ used, can I do a factory reset? Maybe the previous owner messed something up? I see no option for a factory reset.

Thanks

You can reinstall: https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

That would’ve belonged into the start post where you wrote

Yes, you should have done this right away with a used device. Who knows what the previous owner did to it, how he configured it to work with his network and his sources. A reinstall is the only reasonable thing to do. Go for it with the reinstall method ooZee linked.

Reinstalling osmc worked for me now.

Thanks for your help!

1 Like