Setting up an OSMC picture frame on some PIZeroW, random crashes


I have two RP 3B+ hooked to two old monitors, running OSMC/KODI, with Picture Slideshow Screensaver Add-On installed, used exclusively for displaying a random assortment of personal photos in my living room. I can transfer photos across the network into the Pictures folder, the box sits on showing screensaver for weeks at a time no problem… creating an awesome DIY random Picture Frame.
I decided to transition them over to use RPZeroW’s… to use slightly less power, smaller boxes… (and have the 3B+ for more HW intense project). Ordered 2x Vilros RPZW kits, 2x 32gb EVO Select mSD cards. Started the project today. From my imac, using qt_host_installer to setup the SD cards, then slot into the RPZ for initial setup, once theyre running and on network, grab addon: Picture Slideshow, pop out to OSMC setup to Enable Samba share, then start to transfer photos over from iMac. So I am having some random crashing problems… Mainly the boxes definitely cannot receive more than 50-100mb of pictures before they crash, and it was also crashing randomly when trying to update/enable Samba (on one of them several times over), (one also crashed during initial OSMC setup once as well). Sometimes it pops to the sad face, sometimes the screen just locks. I tried using OSMC 2019.06-1 and 2019.05-1. Any input, ideas, links, etc, to help troubleshoot this would be greatly appreciated??? Thanks.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

As oozee has stated, logs will provide the best chance of pinpointing the cause of the crash but, my question is, why OSMC and Kodi for a picture frame application? This is software overkill while you state that your goal here is to simplify. I’m sure there are dozens of tutorials for more streamlined options to achieve your goal.

1 Like

Great, thank you for the quick response and detailed how to:
Here is the first crash just trying to enable the Picture Slideshow Screensaver:

Yeah, when i initially started this project with a couple spare monitors and some 3B+, I looked around for several hours to try and find a solution that would be easy to quickly install and have a good interface. Though OSMC is software overkill for this application, its so simple and easy to work with off the bat, and didnt involve commandline or any extra coding, etc… It has all the features with a few quick settings tweaks: Allows changing of pic display time, changing of transition style, overall quick and easy install, pics can be added over Wifi, stable os/uptime.

Another frowny face while clicking around in Settings:

Here is one from the OTHER box. The screensaver got going on it, but it locked up after a couple mins in.


What type of power supplies were provided?

“Vilros Adapter” 5v 2500ma - model fj-sw7260502500DU
Included in the ~$25 Vilros Raspberry Pi Zero W kit on Amazon

If you swap the two power supplies between the two devices, do the misbehaviors migrate as well?

Yeah, tried this one board with both the PS that came with the kits, as well as the previous one I had here that worked fine for my RP3B+.

Ok, well now you are receiving support in two threads… We need to focus on one. Test with raspbian and report back.

Thanks, yea, its installing now. Crashed on first run, but now at command line.

Installed Lite, it seemed to hang once during install, but upon reboot went right through to command line and logged in no problem. Further testing I installed Full version, got into desktop with no crashes, and it has sat there updating for almost an hour with NO crashing as well… ugh.