Share NFTS formatted HDD via Samba


I have a NTFS formatted USB drive directly connected to my PI. How can I share (read/write) specific folders of that USB drive via Samba?

The USB drive is mounted to /media

Thanks a lot.

Installing Samba server from App Store and it will automatically be shared

I installed from App Store…but it only shares /home/osmc


Tried a reboot since installing this?

yes I already rebooted…Just tried it again.

Is maybe the sequence an issue? The external HDD is connected when I reboot but maybe only mounted after Samba is already started?

How can I manually add a share to Samba?

just rebooted another time and now the HDD is visible via Samba. This is confusing…bot hopefully the topic is now solved.

It seems that osmc/samba doesn’t automatically share USB hard drives anymore. I’ve experienced similar issues recently.

You have to edit the smb.conf. There is a thread floating around with some lines you have to paste into it.

I’ll share the link to the thread with you when I find it again.

Works fine for me. Please provide logs demonstrating an external drive being connected but a Samba share not being created. Without some sort of log its impossible to know why it might not be working for you.

No, you don’t have to edit smb.conf when you installed the version from the APP Store and you are using automounted devices in /media.