Since the latest update, fstab wont automount on boot

Hello,

Since the latest update or two, not sure which…my /etc/fstab entry wont automount.

I have
sleep 3
mount /mnt/nfs
inside of /etc/rc.local

And I have this added in /etc/fstab using openvpn
192.168.88.1:/media /mnt/nfs nfs defaults,nolock,x-systemd.automount 0 0

Now before, it would wait 3 minutes and then prepare to mount. It did mount, but when it was time to scan (using XBMC Library cleaner), it would update at 5 minutes for the first time and then clean both movies and tv shows paths.

But instead, it just gets stuck in PREPARING at the top. The weird thing is, when I login via SSH, I see on my screen it begins to scan, almost like it was validated somehow.

Anyone have a fix to why its stuck on preparing until I login via SSH?

I think you’re a bit confused about how automounting works.

Why do you have a sleep and mount in rc.local ?

If an fstab entry is marked x-systemd.automount then it will automatically mount on first access.

So remove those unnecessary lines in rc.local which will not work anyway because rc.local typically runs before networking is even up.

Then log in with ssh after booting and check with mount whether your nfs mount has mounted.

Ok, I have removed everything from /etc/rc.local that I added and I left fstab with the entry I put above.

Still after booting…if I update the libraries, it gets stuck here on preparing: http://imgur.com/x4cA3ui

Also…I have 3 Pi’s in the household and all 3 are doing exactly this since latest update…

If I login via SSH however, Pi by Pi, I notice as soon as I simply just login to ssh via root or user, that it suddenly starts scanning the movies folder and tv shows folder. But only after I SSH in. That’s why I am curious to whats occuring? Shouldn’t it just mount and update/clean libraries after booting even 10 minutes after booting, without ever needing to login to the server?..Am I missing something?

Thanks!!
Daniel

To get a better understanding of the problem you are experiencing we need more information from you. MOST IMPORTANTLY, you need to provide DIAGNOSTIC LOGS so we can diagnose the problem. If you don’t supply logs, we can’t help you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

You got it.

I tried to replicate the issue and waited the 5 minutes before xbmc library cleaner ran its update and cleaner. It didnt happen so I just simply did a update library through the osmc settings, and it was stuck in ‘Preparing…’ as shown in picture above.

Once I got on my laptop opened up Terminal and logged in via SSH, as soon as I put my password in it changed from Preparing to Scanning the whole library.

I enabled debugger and uploaded the logs after logging in. I did All config files in the log:

http://paste.osmc.io/cubenuneke

Thanks for the help!

Try adding noauto in addition to the x-systemd.automount that you already have on your fstab line.

If that doesn’t work, try enabling “wait for network” in My OSMC networking.

Ok so I did this

192.168.88.1:/media /mnt/nfs nfs defaults,nolock,x-systemd.automount.noauto 0 0

the noauto thing basically did nothing. Never mounted my drive instead I had to manually do it via SSH.

And I did tick the wait for network option in My OSMC but that changed nothing.

I have since removed noauto from fstab and I have rebooted to the same situation, once XBMC Library Updater runs after 5 minutes timer, it sits on Preparing as shown, once logged in via SSH it scans…

Any luck with this one? quite frustrating to say the least

No idea sorry. I’m not seeing the same issue that you are.

I think x-systemd.automount.noauto is not correct, it should be x-systemd.automount,noauto by my understanding.

Well spotted, I had missed that.

Holy crap if this is it lol will test tonight thank you!!! So obvious…

Ah nevermind I tried this with ,noauto added at the end of the segment but still same actually it didn’t mount at all

Here is mine:
192.168.1.10:/volume1/kodi /mnt/kodi nfs noexec,nosuid,nodev,noauto,noatime,rsize=16384,wsize=16384,intr,x-systemd.automount 0 0

It works for me, so if you can’t mount you have something wrong…

  • Wrong nfspath?
  • Not existing mount dir?
  • Incorrect permissions on nfs server?

Well the mount is just fine. I can do ls -lah on /mnt/nfs and everything is there (on my mac the folders mounted are highlighted in green if thats normal?

I am unsure what rsize and wsize mean if I leave those the same but I can try this as well tonight.
Thanks!