Skin shortcuts error after update

I ran an update after getting prompted there was one available for OSMC yesterday. After updating, I get the following error window: “Skin Shorcuts - Unable to build menu” The error message seems to occur every time I go back to my main menu.

I attempted to set my skin views to default and I also tried running a sudo apt-get update && sudo apt-get dist-upgrade, but the issue still occurs. Here is my log file:

Device: (Rasp Pi A/B/2, Vero?) Rasp Pi 2
Installation media: (SDcard, USB, NFS?) SDcard
Connection: (Wired, Wifi?) Wired
Power Supply Type: Dual USB to TV
Power specs: ???
Peripherals: (What devices are connected to your device? USB hub?) USB IR for Ortek/Hama Remote
Storage Device (incl. Network Sharing Protocol): (USB drive, NFS, SMB?) One network drive in SMB
OSMC version: (bottom of the screen in MyOSMC or cat /etc/os-release | grep VERSION_ID) July 2015.07-1
XBMC version: (grep Kodi .kodi//temp/kodi.log | head -2) 17:07:13 8.395875 T:1956544512 NOTICE: Starting Kodi (15.1-RC1 Git:Unknown). Platform: Linux ARM (Thumb) 32-bit
17:07:13 8.395934 T:1956544512 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
Codecs: (mpeg2, vc1?) Yes
Audio/Video Output: (HDMI, AVR, optical?) HDMI
Overclocked: Turbo
Config.txt Extras: hdmi_force_hotplug=1, hdmi_edid_file=1

Wow… First thing you are going to have to do is confirm the issue is still present when powering the pi properly.

Just powered directly to the wall via a 1.8A LG G2 charger that I have and the same issue occurs.

Again, my Pi has been working fine being powered by 2 USB ports on my TV since Raspbmc. This issue only started to occur after the update I ran yesterday. I ran a bunch of updates for OSMC previously with no issues until now.

Thanks for the reply AA.

As of note, another error appeared previously to the shortcut issue that occurred after the automatic update. After trying to run a manual update, it showed up again and I’m still having the shortcut issue:

The OSMC update servers are down, so until they are back up there is no point trying to run a manual update.

I’m unable to run an update in order to fix my problem due to the same "OSMC Update Error - Error installing: armv7-remote-osmc (1.1.6)" that appears during the update.

Anyone have any suggestions?

Yep, please provide proper debug logs so that we are not just guessing.

By the way, what does your problem have to do with this thread ? If it is unrelated you should have started a new thread.

I was hoping that running the latest update would fix my issue since my OSMC build isn’t auto-updating.

I’ll provide a proper log when I get home.


Hi, I’m getting the same error message as the OP on my Pi after running the latest (end of Aug) update. I’ve uploaded all logs now, is this enough info to start to analyse?
Sorry I’m on my phone but the URL is:

1 Like

Copy and paste this via SSH:

sudo -s
systemctl stop mediacenter
if ischroot; then OWNER="1000:1000"; else OWNER="osmc:osmc"; fi
chown -R $OWNER /usr/share/kodi/addons/skin.osmc
chown -R $OWNER /usr/share/kodi/addons/script.module.simplejson
chown -R $OWNER /usr/share/kodi/addons/script.module.unidecode
chown -R $OWNER /usr/share/kodi/addons/script.skinshortcuts
chown -R $OWNER /usr/share/kodi/addons/
systemctl start mediacenter



That worked for me Sam! I am no longer having the issue with “Skin shortcuts” prompts.

Now I just have to get my update issue fixed.

Thanks again! :blush:

This worked for me also!

Thanks Sam.