[Solved] 22 March Update - problems with USB devices?

At this stage, this post is a query or warning about the March upgrade. I’ll seek help about my outstanding problem if I fail tomorrow.

External USB drive
After the March update, one external drive (Toshiba 1TB) was not auto mounting while the other (2TB Toshiba) continued fine on a Pi2. USB devices are all powered from a hub. The 1TB drive works perfectly on a PC under Kubuntu 16.04. The drive was visible as a device to the Pi2 but could not be mounted. The error message from modprobe referred to ntfs-3g and an internet search suggested missing software or kernel module depending on the site. This gave the clue. The 2TB drive is formatted as ext4 while the 1TB drive was ntfs.

After moving recordings off, reformatting to ext4 and reinstating files, the drive works perfectly again. So there is an issue with ntfs formatted devices?

At the same time, TVHeadend no longer sees the TV dongle. OSMC seems to connect to TVHeadend which is also fully accessible through a browser. The TV adapter simply isn’t being recognised. So again, an issue with the March upgrade?

I’ll see if my old notes from last year about installing TVHeadend help. If not, I’ll be back.


No – nothing has changed re. NTFS.

NTFS can be handled by FUSE or the kernel, so a module is not always necessary.

Again, not that I’m aware of. I haven’t changed anything related to DVB at all in this update.

I would check why you’re having problems with USB peripherals all of a sudden.

I think it was on the re-boot after this upgrade that I lost my DVB stick/tvheadend. I checked that the PVR add-on was still enabled, re-booted again and all was then well. I’m not using the App Store TVH though, ymmv.

If you’re using TVHeadend via another installation method or repository, it’s not supported.
That may have updated on its own and it’s impossible for us to track that or provide any support for this. We check every version of TVH before shipping which is why we recommend sticking with our App Store. But we don’t have the time or resources to track upstream changes and what they may bring in.

If there’s a specific reason you use upstream TVH, we can look at it and add any improvements or fixes to our App Store version.


Noted, Sam. I can’t remember now exactly why I installed (compiled) a later version. I was working with the devs at tvh at one point to get some automatic tuning problems sorted out. Still using 4.1-327 years later. When I get time, I’ll try the App Store version to see if there’s anything to straighten out.

On reflection, this is unlikely to be USB related so sorry for butting in!

Solved for the most part.

After struggling with TVH without any luck then discovering the mouse also wasn’t working, I reinstalled from a clean image of 2017-3-22.

All peripherals & functionality appeared OK - so I turned to Tvheadend:

  1. OSMC needs either the bridge or driver firmware for the Leadtek WinFast Dual TV dongle (I wasn’t watching closely when I copied them into /lib/firmware as to which one was missing). TVH saw the TV adaptors immediately thereafter. Both firmware files were present in the previous installation by the way - that’s where I got them from.

  2. I forgot to return to the DVB Input page to link them to the new network (perhaps that should be in bold in the many how-tos I had open eventually) but my mistake - and time wasted.

  3. TVH would not record to the external drive as has been the setup for over a year. Again after checking a few assumptions, I noticed my glaring error: I had missed the Save button to the far left. :flushed:

Lessons for beginners!

So all seems well. Thanks for the attention. I still think something happened during the upgrade as the mouse & 1 TB drive dropped out and the shutdown log was appearing over the splash screen - Maybe an accumulation of earlier changes to the system I’ve made !.

But I do now have a nice new Pi2+OSMC. :slight_smile:

Don’t forget to make a backup image of that card! :slight_smile: